diff configure.in @ 108627:4b6058a65883

* configure.in (ns_appbindir, ns_appresdir): Set using $ns_appdir. * configure: Regenerate.
author Glenn Morris <rgm@gnu.org>
date Sun, 16 May 2010 16:38:13 -0700
parents 840953137f6b
children a53949523193
line wrap: on
line diff
--- a/configure.in	Sun May 16 16:31:05 2010 -0700
+++ b/configure.in	Sun May 16 16:38:13 2010 -0700
@@ -1466,14 +1466,14 @@
   if test "${opsys}" = darwin; then
      NS_IMPL_COCOA=yes
      ns_appdir=`pwd`/nextstep/Emacs.app/
-     ns_appbindir=`pwd`/nextstep/Emacs.app/Contents/MacOS/
-     ns_appresdir=`pwd`/nextstep/Emacs.app/Contents/Resources
+     ns_appbindir=${ns_appdir}Contents/MacOS/
+     ns_appresdir=${ns_appdir}Contents/Resources
      ns_appsrc=${srcdir}/nextstep/Cocoa/Emacs.base
   elif test -f $GNUSTEP_CONFIG_FILE; then
      NS_IMPL_GNUSTEP=yes
      ns_appdir=`pwd`/nextstep/Emacs.app/
-     ns_appbindir=`pwd`/nextstep/Emacs.app/
-     ns_appresdir=`pwd`/nextstep/Emacs.app/Resources
+     ns_appbindir=${ns_appdir}
+     ns_appresdir=${ns_appdir}Resources
      ns_appsrc=${srcdir}/nextstep/GNUstep/Emacs.base
      dnl FIXME sourcing this 3 times in subshells seems inefficient.
      GNUSTEP_MAKEFILES="$(. $GNUSTEP_CONFIG_FILE; echo $GNUSTEP_MAKEFILES)"