diff configure.in @ 108866:4e8dcb0d6fe0

NOT_C_CODE is always true now. * configure.in (AH_BOTTOM): Remove NOT_C_CODE test, it is always true. * m/ia64.h, s/gnu-linux.h, s/gnu.h, s/netbsd.h, s/usg5-4.h: Remove NOT_C_CODE tests, it is always true now. * nt/config.nt: Remove NOT_C_CODE tests, it is always true now. * admin/CPP-DEFINES: Remove NOT_C_CODE.
author Glenn Morris <rgm@gnu.org>
date Wed, 02 Jun 2010 22:29:02 -0700
parents 8fccefed04ac
children 3ff97bad1c47
line wrap: on
line diff
--- a/configure.in	Wed Jun 02 21:48:10 2010 -0400
+++ b/configure.in	Wed Jun 02 22:29:02 2010 -0700
@@ -3546,13 +3546,8 @@
 
 /* Some of the files of Emacs which are intended for use with other
    programs assume that if you have a config.h file, you must declare
-   the type of getenv.
-
-   This declaration shouldn't appear when alloca.s or Makefile.in
-   includes config.h.  */
-#ifndef NOT_C_CODE
+   the type of getenv.  */
 extern char *getenv ();
-#endif
 
 /* These default definitions are good for almost all machines.
    The exceptions override them in m/MACHINE.h.  */
@@ -3593,17 +3588,18 @@
 # endif  /* GCC.  */
 #endif /* __P */
 
-/* Don't include "string.h" or <stdlib.h> in non-C code.  */
-#ifndef NOT_C_CODE
 #ifdef HAVE_STRING_H
 #include "string.h"
 #endif
+
 #ifdef HAVE_STRINGS_H
 #include "strings.h"  /* May be needed for bcopy & al.  */
 #endif
+
 #ifdef HAVE_STDLIB_H
 #include <stdlib.h>
 #endif
+
 #ifdef HAVE_ALLOCA_H
 # include <alloca.h>
 #elif defined __GNUC__
@@ -3617,10 +3613,10 @@
 # endif
 void *alloca (size_t);
 #endif
+
 #ifndef HAVE_SIZE_T
 typedef unsigned size_t;
 #endif
-#endif /* NOT_C_CODE */
 
 /* Define HAVE_X_I18N if we have usable i18n support.  */