diff configure.in @ 94593:537c28766f1d

(x_libraries): Remove standard 64-bit directories - experimental workaround for minor autoconf bug.
author Glenn Morris <rgm@gnu.org>
date Sat, 03 May 2008 18:59:31 +0000
parents ca9efc5939fc
children 100982f1144d
line wrap: on
line diff
--- a/configure.in	Sat May 03 18:57:42 2008 +0000
+++ b/configure.in	Sat May 03 18:59:31 2008 +0000
@@ -1339,6 +1339,16 @@
   window_system=x11
 fi
 
+## Workaround for bug in autoconf <= 2.62.
+## http://lists.gnu.org/archive/html/emacs-devel/2008-04/msg01551.html
+## No need to do anything special for these standard directories.
+## This is an experiment, take it out if it causes problems.
+if test -n "${x_libraries}" && test x"${x_libraries}" != xNONE; then
+   
+   x_libraries=`echo :${x_libraries}: | sed -e 's|:/usr/lib64:|:|g' -e 's|:/lib64:|:|g' -e 's|^:||' -e 's|:$||'`
+
+fi
+
 if test "${x_libraries}" != NONE; then
   if test -n "${x_libraries}"; then
     LD_SWITCH_X_SITE=-L`echo ${x_libraries} | sed -e "s/:/ -L/g"`