diff configure.in @ 30078:58ce7aad3fff

* configure.in: Check for <soundcard.h>. Look for ossaudio library, and set LIBSOUND accordingly.
author Ken Raeburn <raeburn@raeburn.org>
date Wed, 05 Jul 2000 19:18:52 +0000
parents 61037d088180
children ad53f03540e3
line wrap: on
line diff
--- a/configure.in	Wed Jul 05 17:35:45 2000 +0000
+++ b/configure.in	Wed Jul 05 19:18:52 2000 +0000
@@ -1157,7 +1157,10 @@
 AC_AIX
 
 # Sound support for GNU/Linux and the free BSDs.
-AC_CHECK_HEADERS(machine/soundcard.h sys/soundcard.h)
+AC_CHECK_HEADERS(machine/soundcard.h sys/soundcard.h soundcard.h)
+# Emulation library used on NetBSD.
+AC_CHECK_LIB(ossaudio, _oss_ioctl, LIBSOUND=-lossaudio, LIBSOUND=)
+AC_SUBST(LIBSOUND)
 
 dnl checks for header files
 AC_CHECK_HEADERS(sys/select.h sys/timeb.h sys/time.h unistd.h utime.h \