diff configure.in @ 94119:5b10e5646973

* configure.in (SYNC_INPUT): Use OPTION_DEFAULT_ON and AC_DEFINE rather than change CPPFLAGS. (HAVE_GTK): Rename to USE_GTK. * Makefile.in: Don't use HAVE_GTK and don't -DUSE_GTK since it's now done in config.h.
author Stefan Monnier <monnier@iro.umontreal.ca>
date Wed, 16 Apr 2008 19:53:06 +0000
parents 4bbc5d00d3eb
children dfdc13740582
line wrap: on
line diff
--- a/configure.in	Wed Apr 16 17:34:43 2008 +0000
+++ b/configure.in	Wed Apr 16 19:53:06 2008 +0000
@@ -99,6 +99,11 @@
 
 OPTION_DEFAULT_ON([sound],[don't compile with sound support])
 
+OPTION_DEFAULT_ON([sync-input],[Process async input synchronously])
+if test "$with_sync_input" = yes; then
+   AC_DEFINE(SYNC_INPUT, 1, [Process async input synchronously.])
+fi
+
 dnl FIXME currently it is not the last.
 dnl This should be the last --with option, because --with-x is
 dnl added later on when we find the path of X, and it's best to
@@ -173,12 +178,6 @@
       USE_FONT_BACKEND=$enableval,
       USE_FONT_BACKEND=yes)
 
-## Enabled by default.
-AC_ARG_ENABLE(sync-input,
-[AS_HELP_STRING([--disable-sync-input], [don't compile code with sync-input])],
-      USE_SYNC_INPUT=$enableval,
-      USE_SYNC_INPUT=yes)
-
 AC_ARG_ENABLE(asserts,
 [AS_HELP_STRING([--enable-asserts], [compile code with asserts enabled])],
       USE_XASSERTS=$enableval,
@@ -1670,7 +1669,7 @@
     fi
   else
     HAVE_GTK=yes
-    AC_DEFINE(HAVE_GTK, 1, [Define to 1 if using GTK.])
+    AC_DEFINE(USE_GTK, 1, [Define to 1 if using GTK.])
     USE_X_TOOLKIT=none
     if $PKG_CONFIG --atleast-version=2.10 gtk+-2.0; then
       :
@@ -3008,11 +3007,6 @@
    CPPFLAGS="$CPPFLAGS -DXASSERTS=1"
 fi
 
-if test $USE_SYNC_INPUT = yes; then
-   echo "  Compiling with sync input."
-   CPPFLAGS="$CPPFLAGS -DSYNC_INPUT=1"
-fi
-
 echo
 
 if test "$USE_X_TOOLKIT" = GTK; then