diff configure.in @ 112123:5e63c33ad48c

Don't use $MAKEINFO for both a flag and a program. * configure.in (HAVE_MAKEINFO): New output variable. (MAKEINFO): Reset to "makeinfo" if not found. * Makefile.in (install-arch-indep, info): Replace MAKEINFO = off with HAVE_MAKEINFO = no.
author Glenn Morris <rgm@gnu.org>
date Tue, 04 Jan 2011 23:10:47 -0800
parents a456b0a17885
children 4dbda0e7c8bf
line wrap: on
line diff
--- a/configure.in	Tue Jan 04 23:04:51 2011 -0800
+++ b/configure.in	Tue Jan 04 23:10:47 2011 -0800
@@ -791,9 +791,12 @@
 ## should test for it as it does for any other build requirement.
 ## We use the presence of $srcdir/info/emacs to distinguish a release,
 ## with pre-built manuals, from a Bazaar checkout.
+HAVE_MAKEINFO=yes
+
 if test "$MAKEINFO" = "no"; then
+  MAKEINFO=makeinfo
   if test "x${with_makeinfo}" = "xno"; then
-    MAKEINFO=off
+    HAVE_MAKEINFO=no
   elif test ! -e $srcdir/info/emacs; then
     AC_MSG_ERROR( [You do not seem to have makeinfo >= 4.6, and your
 source tree does not seem to have pre-built manuals in the `info' directory.
@@ -801,6 +804,7 @@
 with the `--without-makeinfo' option to build without the manuals.] )
   fi
 fi
+AC_SUBST(HAVE_MAKEINFO)
 
 dnl Add our options to ac_link now, after it is set up.