diff configure.in @ 33635:6242368d9e4c

Use -traditional with GNU cpp.
author Gerd Moellmann <gerd@gnu.org>
date Mon, 20 Nov 2000 14:07:03 +0000
parents 4a8304668f5c
children cdbdcca9452f
line wrap: on
line diff
--- a/configure.in	Mon Nov 20 14:01:35 2000 +0000
+++ b/configure.in	Mon Nov 20 14:07:03 2000 +0000
@@ -2257,6 +2257,13 @@
 echo creating src/epaths.h
 make epaths-force
 
+# As of 2000-11-19, newest development versions of GNU cpp preprocess
+# `..' to `. .'  unless invoked with -traditional
+
+if [ x$GCC = xyes && x$NON_GNU_CPP" = x ]; then
+  CPPFLAGS="$CPPFLAGS -traditional"
+fi
+
 echo creating lib-src/Makefile
 ( cd lib-src
   rm -f junk.c junk1.c junk2.c