diff configure.in @ 108966:6f4e41648c3f

Make compressing the info files optional. * configure.in (--without-compress-info): New option. (GZIP_INFO): New output variable. * Makefile.in (GZIP_INFO): New, set by configure. (install-arch-indep): Don't gzip info pages if GZIP_INFO is nil. Handle man pages in the same way. * etc/NEWS: Re-order installation section, and add new item.
author Glenn Morris <rgm@gnu.org>
date Thu, 10 Jun 2010 20:35:40 -0700
parents 38cf1b719b59
children b5f73bf59a4f 68616bb3ae25
line wrap: on
line diff
--- a/configure.in	Thu Jun 10 14:56:11 2010 +0200
+++ b/configure.in	Thu Jun 10 20:35:40 2010 -0700
@@ -174,6 +174,16 @@
 dnl http://lists.gnu.org/archive/html/emacs-devel/2008-04/msg01844.html
 OPTION_DEFAULT_ON([makeinfo],[don't require makeinfo for building manuals])
 
+## This is an option because I do not know if all info/man support
+## compressed files, nor how to test if they do so.
+OPTION_DEFAULT_ON([compress-info],[don't compress the installed Info pages])
+if test $with_compress_info = yes; then
+   GZIP_INFO=yes
+else
+   GZIP_INFO=
+fi
+AC_SUBST(GZIP_INFO)
+
 AC_ARG_WITH([pkg-config-prog],dnl
 [AS_HELP_STRING([--with-pkg-config-prog=PATH],
                   [path to pkg-config for finding GTK and librsvg])])