diff configure.in @ 29385:74d1eeb89c85

Don't specify -n32 flag for mips-sgi-irix6.5. Check for struct exception. Use AC_SYS_LARGEFILE and move ftello test.
author Dave Love <fx@gnu.org>
date Fri, 02 Jun 2000 15:38:39 +0000
parents 809933264ea6
children 35fabb4b6bab
line wrap: on
line diff
--- a/configure.in	Fri Jun 02 15:37:55 2000 +0000
+++ b/configure.in	Fri Jun 02 15:38:39 2000 +0000
@@ -788,13 +788,14 @@
     # so that, for instance, grepping for `free' in stdlib.h fails and
     # AC_HEADER_STD_C fails.   (MIPSPro 7.2.1.2m compilers, Irix 6.5.3m).
     NON_GNU_CPP="/lib/cpp -D_LANGUAGE_C"
-    NON_GCC_TEST_OPTIONS="-n32 -D_LANGUAGE_C"
+    NON_GCC_TEST_OPTIONS="-D_LANGUAGE_C"
   ;;
   mips-sgi-irix6* )
     machine=iris4d opsys=irix6-0
     # It's not clear whether -D_LANGUAGE_C is necessary as it is for 6.5,
     # but presumably it does no harm.
     NON_GNU_CPP="/lib/cpp -D_LANGUAGE_C"
+    # -32 probably isn't necessary in later v.6s -- anyone know which?
     NON_GCC_TEST_OPTIONS=-32
   ;;
   mips-sgi-irix5.[01]* )
@@ -1209,6 +1210,15 @@
   AC_DEFINE(HAVE_TIMEVAL)
 fi
 
+AC_CACHE_CHECK(for struct exception, emacs_cv_struct_exception,
+AC_TRY_COMPILE([#include <math.h>], 
+[static struct exception x; x.arg1 = x.arg2 = x.retval; x.name = ""; x.type = 1;],
+  emacs_cv_struct_exception=yes, emacs_cv_struct_exception=no))
+HAVE_EXCEPTION=$emacs_cv_struct_exception
+if test $emacs_cv_struct_exception != yes; then
+  AC_DEFINE(NO_MATHERR)
+fi
+
 dnl checks for structure members
 AC_STRUCT_TM
 AC_STRUCT_TIMEZONE
@@ -1857,14 +1867,18 @@
 random lrand48 bcopy bcmp logb frexp fmod rint cbrt ftime res_init setsid \
 strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
 utimes setrlimit setpgid getcwd shutdown strftime getaddrinfo \
-__fpending ftello getloadavg mblen mbrlen strsignal setitimer ualarm)
+__fpending getloadavg mblen mbrlen strsignal setitimer ualarm)
 
 AC_FUNC_MKTIME
 if test "$ac_cv_func_working_mktime" = no; then
   AC_DEFINE(BROKEN_MKTIME)
 fi
 
-# UNIX98 PTYs.
+AC_SYS_LARGEFILE
+AC_CHECK_FUNCS(ftello)
+
+# UNIX98 PTYs.  AC_SYS_LARGEFILE should have defined _XOPEN_SOURCE
+# if we need it.
 AC_CHECK_FUNCS(grantpt)
 
 # PTY-related GNU extensions.