diff configure.in @ 26498:794e4734de4b

Fix NON_GNU_CPP for Irix 6 to avoid failing tests.
author Dave Love <fx@gnu.org>
date Thu, 18 Nov 1999 17:44:32 +0000
parents 09ba127d578d
children b32d82817493
line wrap: on
line diff
--- a/configure.in	Thu Nov 18 16:56:16 1999 +0000
+++ b/configure.in	Thu Nov 18 17:44:32 1999 +0000
@@ -748,12 +748,17 @@
   ;;
   mips-sgi-irix6.5 )
     machine=iris4d opsys=irix6-5
-    NON_GNU_CPP=/lib/cpp
-    NON_GCC_TEST_OPTIONS="-n32 -G0"
+    # Without defining _LANGUAGE_C, things get masked out in the headers
+    # so that, for instance, grepping for `free' in stdlib.h fails and
+    # AC_HEADER_STD_C fails.   (MIPSPro 7.2.1.2m compilers, Irix 6.5.3m).
+    NON_GNU_CPP="/lib/cpp -D_LANGUAGE_C"
+    NON_GCC_TEST_OPTIONS="-n32 -G0 -D_LANGUAGE_C"
   ;;
   mips-sgi-irix6* )
     machine=iris4d opsys=irix6-0
-    NON_GNU_CPP=/lib/cpp
+    # It's not clear whether -D_LANGUAGE_C is necessary as for 6.5,
+    # but presumably it does no harm.
+    NON_GNU_CPP="/lib/cpp -D_LANGUAGE_C"
     NON_GCC_TEST_OPTIONS=-32
   ;;
   mips-sgi-irix5.[01]* )