diff configure.in @ 103717:7bebd9bb90fc

(--enable-checking, --enable-profiling): Use AS_HELP_STRING.
author Andreas Schwab <schwab@linux-m68k.org>
date Sat, 04 Jul 2009 08:12:10 +0000
parents bae3b52cda07
children 8e3613329929
line wrap: on
line diff
--- a/configure.in	Fri Jul 03 15:32:02 2009 +0000
+++ b/configure.in	Sat Jul 04 08:12:10 2009 +0000
@@ -210,12 +210,12 @@
 fi)
 
 AC_ARG_ENABLE(checking,
-[  --enable-checking[=LIST]
-			  enable expensive run-time checks.  With LIST,
-			  enable only specific categories of checks.
-			  Categories are: all,yes,no.
-			  Flags are: stringbytes, stringoverrun, stringfreelist,
-			  xmallocoverrun, conslist],
+[AS_HELP_STRING([--enable-checking@<:@=LIST@:>@],
+		[enable expensive run-time checks.  With LIST,
+		 enable only specific categories of checks.
+		 Categories are: all,yes,no.
+		 Flags are: stringbytes, stringoverrun, stringfreelist,
+		 xmallocoverrun, conslist])],
 [ac_checking_flags="${enableval}"],[])
 IFS="${IFS= 	}"; ac_save_IFS="$IFS"; IFS="$IFS,"
 for check in $ac_checking_flags
@@ -274,9 +274,9 @@
 fi
 
 AC_ARG_ENABLE(profiling,
-[  --enable-profiling
-			  Build emacs with profiling support.
-			  This might not work on all platforms.],
+[AS_HELP_STRING([--enable-profiling],
+		[build emacs with profiling support.
+		 This might not work on all platforms])],
 [ac_enable_profiling="${enableval}"],[])
 if test x$ac_enable_profiling != x ; then
    PROFILING_CFLAGS="-DPROFILING=1 -pg"