diff configure.in @ 47249:7c7faeac1188

Look for LessTif in /usr/X11R6/LessTif/ before Motif. Handle $GCC_LINK_TEST_OPTIONS and $NON_GCC_LINK_TEST_OPTIONS after the AC_PROG_... macros.
author Richard M. Stallman <rms@gnu.org>
date Thu, 05 Sep 2002 22:58:05 +0000
parents 03209f3ee750
children e85548b04ce6
line wrap: on
line diff
--- a/configure.in	Thu Sep 05 18:42:13 2002 +0000
+++ b/configure.in	Thu Sep 05 22:58:05 2002 +0000
@@ -1200,16 +1200,6 @@
   CC="$CC $NON_GCC_TEST_OPTIONS"
 fi
 
-if test x$GCC = xyes && test "x$GCC_LINK_TEST_OPTIONS" != x
-then
-  ac_link="$ac_link $GCC_LINK_TEST_OPTIONS"
-fi
-
-if test x$GCC = x && test "x$NON_GCC_LINK_TEST_OPTIONS" != x
-then
-  ac_link="$ac_link $NON_GCC_LINK_TEST_OPTIONS"
-fi
-
 #### Some other nice autoconf tests.  If you add a test here which
 #### should make an entry in src/config.h, don't forget to add an
 #### #undef clause to src/config.h.in for autoconf to modify.
@@ -1223,6 +1213,18 @@
   AC_PROG_RANLIB
 fi
 
+dnl Add our options to ac_link now, after it is set up.
+
+if test x$GCC = xyes && test "x$GCC_LINK_TEST_OPTIONS" != x
+then
+  ac_link="$ac_link $GCC_LINK_TEST_OPTIONS"
+fi
+
+if test x$GCC = x && test "x$NON_GCC_LINK_TEST_OPTIONS" != x
+then
+  ac_link="$ac_link $NON_GCC_LINK_TEST_OPTIONS"
+fi
+
 dnl checks for Unix variants
 AC_AIX
 
@@ -1817,6 +1819,14 @@
 fi
 
 if test "${USE_X_TOOLKIT}" = "MOTIF"; then
+  AC_CACHE_CHECK(for LessTif where some systems put it,
+  [AC_TRY_COMPILE([#include </usr/X11R6/LessTif/Motif1.2/include/Xm/Xm.h>],
+    [int x = 5;],
+    emacs_cv_lesstif=yes, emacs_cv_lesstif=no)
+  if test $emacs_cv_lesstif = yes; then
+    CPPFLAGS="-I/usr/X11R6/LessTif/Motif1.2/include $CPPFLAGS"
+    LDFLAGS="-L/usr/X11R6/LessTif/Motif1.2/lib $LDFLAGS"
+  fi
   AC_CACHE_CHECK(for Motif version 2.1, emacs_cv_motif_version_2_1,
   [AC_TRY_COMPILE([#include <Xm/Xm.h>],
     [#if XmVERSION > 2 || (XmVERSION == 2 && XmREVISION >= 1)