diff configure.in @ 29253:809933264ea6

Add check for speed_t typedef.
author Gerd Moellmann <gerd@gnu.org>
date Fri, 26 May 2000 15:56:13 +0000
parents 18ae8656c122
children 74d1eeb89c85
line wrap: on
line diff
--- a/configure.in	Fri May 26 15:52:33 2000 +0000
+++ b/configure.in	Fri May 26 15:56:13 2000 +0000
@@ -1184,6 +1184,14 @@
 dnl checks for typedefs
 AC_TYPE_SIGNAL
 
+dnl Check for speed_t typedef.
+AC_CACHE_CHECK(for speed_t, emacs_cv_speed_t,
+AC_TRY_COMPILE([#include <termios.h>], [speed_t x = 1;],
+  emacs_cv_speed_t=yes))
+if test $emacs_cv_speed_t = yes; then
+  AC_DEFINE(HAVE_SPEED_T)
+fi
+
 AC_CACHE_CHECK(for struct timeval, emacs_cv_struct_timeval,
 AC_TRY_COMPILE([#ifdef TIME_WITH_SYS_TIME
 #include <sys/time.h>