diff configure.in @ 43577:849bcdc2a256

<making srcdir absolute>: Verify that PWD is correct, not just well-formed and valid.
author Richard M. Stallman <rms@gnu.org>
date Wed, 27 Feb 2002 03:53:03 +0000
parents 5fcba75d6dd8
children 023476a7048a baa14ec2c76b
line wrap: on
line diff
--- a/configure.in	Tue Feb 26 23:02:14 2002 +0000
+++ b/configure.in	Wed Feb 27 03:53:03 2002 +0000
@@ -114,7 +114,10 @@
   . )
     ## We may be able to use the $PWD environment variable to make this
     ## absolute.  But sometimes PWD is inaccurate.
-    if test ".${PWD}" != "." && test ".`(cd ${PWD} ; sh -c pwd)`" = ".${PWD}"  ;
+    ## Note: we used to use ${PWD} at the end instead of `pwd`,
+    ## but that tested only for a well-formed and valid PWD,
+    ## it did not object when PWD was well-formed and valid but just wrong.
+    if test ".${PWD}" != "." && test ".`(cd ${PWD} ; sh -c pwd)`" = ".`pwd`"  ;
     then
       srcdir="$PWD"
     else
@@ -355,6 +358,11 @@
     ## operating system.
   ;;
 
+  ## Compaq Nonstop
+  mips-compaq-nonstopux* )
+    machine=nonstopux opsys=nonstopux
+    ;;
+
   ## Convex
   *-convex-bsd* | *-convex-convexos* )
     machine=convex opsys=bsd4-3