diff configure.in @ 83275:87d0734390da

Revert changes that were committed by mistake in the previous patch. git-archimport-id: lorentey@elte.hu--2004/emacs--multi-tty--0--patch-315
author Karoly Lorentey <lorentey@elte.hu>
date Tue, 22 Mar 2005 17:58:23 +0000
parents c22274b1aa9b
children ad07ff6e4555
line wrap: on
line diff
--- a/configure.in	Tue Mar 22 15:00:17 2005 +0000
+++ b/configure.in	Tue Mar 22 17:58:23 2005 +0000
@@ -3126,14 +3126,6 @@
 	CPP_NEED_TRADITIONAL=no,
 	CPP_NEED_TRADITIONAL=yes)
 
-## New-fangled C preprocessors consider `//' to start a one-line comment.
-## The -ansi option forces GCC's cpp to revert to the old behavior.
-
-AC_EGREP_CPP(yes//yes,
-	[yes//yes],
-	CPP_NEED_ANSI=no,
-	CPP_NEED_ANSI=yes)
-
 AC_OUTPUT(Makefile lib-src/Makefile.c:lib-src/Makefile.in oldXMenu/Makefile \
 	man/Makefile lwlib/Makefile src/Makefile.c:src/Makefile.in \
 	lisp/Makefile lispref/Makefile lispintro/Makefile leim/Makefile, [
@@ -3168,13 +3160,6 @@
   CPPFLAGS="$CPPFLAGS -traditional"
 fi
 
-# Recent GNU cpp versions understand C++-style one-line comments
-# unless invoked with -ansi.  (Works with GCC 3.3, 3.4, 4.0)
-
-if test "x$GCC" = xyes && test "x$CPP_NEED_ANSI" = xyes; then
-  CPPFLAGS="$CPPFLAGS -ansi"
-fi
-
 echo creating lib-src/Makefile
 ( cd lib-src
   rm -f junk.c junk1.c junk2.c
@@ -3215,7 +3200,7 @@
 # This is how we know whether to re-run configure in certain cases.
 touch src/config.stamp
 
-], [GCC="$GCC" NON_GNU_CPP="$NON_GNU_CPP" CPP="$CPP" CPP_NEED_TRADITIONAL="$CPP_NEED_TRADITIONAL" CPP_NEED_ANSI="$CPP_NEED_ANSI" CPPFLAGS="$CPPFLAGS"])
+], [GCC="$GCC" NON_GNU_CPP="$NON_GNU_CPP" CPP="$CPP" CPP_NEED_TRADITIONAL="$CPP_NEED_TRADITIONAL" CPPFLAGS="$CPPFLAGS"])
 
 m4_if(dnl	Do not change this comment
    arch-tag: 156a4dd5-bddc-4d18-96ac-f37742cf6a5e