diff configure.in @ 50166:8b4f58acd499

Check for need for bigtoc support on IBM AIX for solving a linker table overflow problem.
author Francesco Potortì <pot@gnu.org>
date Sun, 16 Mar 2003 22:30:36 +0000
parents 088ec1541d38
children ea2fa27f60d7
line wrap: on
line diff
--- a/configure.in	Sun Mar 16 22:13:53 2003 +0000
+++ b/configure.in	Sun Mar 16 22:30:36 2003 +0000
@@ -1685,6 +1685,22 @@
   HAVE_XFREE386=no
 fi
 AC_MSG_RESULT($HAVE_XFREE386)
+  
+dnl Check for need for bigtoc support on IBM AIX
+
+case ${host_os} in
+aix*)
+  AC_CACHE_CHECK([for -bbigtoc option], [gdb_cv_bigtoc], [
+    case $GCC in
+    yes) gdb_cv_bigtoc=-Wl,-bbigtoc ;;
+    *) gdb_cv_bigtoc=-bbigtoc ;;
+    esac
+
+    LDFLAGS=$LDFLAGS\ $gdb_cv_bigtoc
+    AC_TRY_LINK([], [int i;], [], [gdb_cv_bigtoc=])
+  ])
+  ;;
+esac
 
 # Change CFLAGS and CPPFLAGS temporarily so that C_SWITCH_X_SITE gets
 # used for the tests that follow.  We set them back to REAL_CFLAGS and