diff configure.in @ 92737:8b55b3cdebda

Add --enable-sync-input, default yes.
author Jan Djärv <jan.h.d@swipnet.se>
date Tue, 11 Mar 2008 08:13:59 +0000
parents 66d896123af5
children 87ea46f93e54
line wrap: on
line diff
--- a/configure.in	Tue Mar 11 08:04:35 2008 +0000
+++ b/configure.in	Tue Mar 11 08:13:59 2008 +0000
@@ -173,6 +173,11 @@
       USE_FONT_BACKEND=$enableval,
       USE_FONT_BACKEND=yes)
 
+AC_ARG_ENABLE(sync-input,
+[AS_HELP_STRING([--enable-sync-input], [compile code with sync-input])],
+      USE_SYNC_INPUT=$enableval,
+      USE_SYNC_INPUT=yes)
+
 AC_ARG_ENABLE(asserts,
 [AS_HELP_STRING([--enable-asserts], [compile code with asserts enabled])],
       USE_XASSERTS=$enableval,
@@ -3001,9 +3006,15 @@
 if test $USE_XASSERTS = yes; then
    echo "  Compiling with asserts turned on."
    CPPFLAGS="$CPPFLAGS -DXASSERTS=1"
-   echo
 fi
 
+if test $USE_SYNC_INPUT = yes; then
+   echo "  Compiling with sync input."
+   CPPFLAGS="$CPPFLAGS -DSYNC_INPUT=1"
+fi
+
+echo
+
 if test "$USE_X_TOOLKIT" = GTK; then
   case "$canonical" in
   *cygwin*)