diff configure.in @ 48080:8ebe39e6efe1

Require autoconf 2.53. Test for pty.h, sys/mman.h, sys/param.h, mremap, memmove. (AH_BOTTOM): Maybe include strings.h. Add local variables for mode. (AC_PROG_YACC): Deleted. (size_t): Use AC_CHECK_TYPES. (AH_TOP): Up-date copyright.
author Dave Love <fx@gnu.org>
date Wed, 30 Oct 2002 18:52:27 +0000
parents 23ae5fa03fc5
children 0230b8ae41f0
line wrap: on
line diff
--- a/configure.in	Wed Oct 30 18:50:35 2002 +0000
+++ b/configure.in	Wed Oct 30 18:52:27 2002 +0000
@@ -23,7 +23,7 @@
 dnl  Free Software Foundation, Inc., 59 Temple Place - Suite 330,
 dnl  Boston, MA 02111-1307, USA.
 
-AC_PREREQ(2.51)dnl
+AC_PREREQ(2.53)dnl
 AC_INIT(src/lisp.h)
 AC_CONFIG_HEADER(src/config.h:src/config.in)
 
@@ -1219,7 +1219,6 @@
 AC_PROG_LN_S
 AC_PROG_CPP
 AC_PROG_INSTALL
-AC_PROG_YACC
 if test "x$RANLIB" = x; then
   AC_PROG_RANLIB
 fi
@@ -1397,7 +1396,8 @@
 dnl checks for header files
 AC_CHECK_HEADERS(sys/select.h sys/timeb.h sys/time.h unistd.h utime.h \
   linux/version.h sys/systeminfo.h termios.h limits.h string.h stdlib.h \
-  termcap.h stdio_ext.h fcntl.h term.h strings.h coff.h)
+  termcap.h stdio_ext.h fcntl.h term.h strings.h coff.h pty.h sys/mman.h \
+  sys/param.h)
 AC_HEADER_STDC
 AC_HEADER_TIME
 AC_DECL_SYS_SIGLIST
@@ -2086,7 +2086,7 @@
 utimes setrlimit setpgid getcwd getwd shutdown strftime getaddrinfo \
 __fpending mblen mbrlen mbsinit strsignal setitimer ualarm index rindex \
 sendto recvfrom getsockopt setsockopt getsockname getpeername \
-gai_strerror mkstemp getline getdelim)
+gai_strerror mkstemp getline getdelim mremap memmove)
 
 AC_CHECK_HEADERS(sys/un.h)
 
@@ -2290,8 +2290,7 @@
 
 AC_FUNC_FORK
 
-# Fixme: This should be replaced when we have autoconf 2.14.
-AC_SIZE_T
+AC_CHECK_TYPES(size_t)
 
 # Set up the CFLAGS for real compilation, so we can substitute it.
 CFLAGS="$REAL_CFLAGS"
@@ -2401,8 +2400,8 @@
 AC_CHECK_HEADERS(nlist.h, [AC_DEFINE(NLIST_STRUCT, 1,
                  [Define to 1 if you have <nlist.h>.])])
 
-AH_TOP([/* GNU Emacs site configuration template file.  -*- C -*-
-   Copyright (C) 1988, 1993, 1994, 1999, 2000 Free Software Foundation, Inc.
+AH_TOP([/* GNU Emacs site configuration template file.
+   Copyright (C) 1988, 93, 94, 99, 2000, 2002 Free Software Foundation, Inc.
 
 This file is part of GNU Emacs.
 
@@ -2602,6 +2601,9 @@
 #ifdef HAVE_STRING_H
 #include "string.h"
 #endif
+#ifdef HAVE_STRINGS_H
+#include "strings.h"  /* May be needed for bcopy & al. */
+#endif
 #ifdef HAVE_STDLIB_H
 #include <stdlib.h>
 #endif
@@ -2630,6 +2632,12 @@
 #else
 #define NO_RETURN	/* nothing */
 #endif
+
+/* 
+Local variables:
+mode: c
+End:
+*/
 ])dnl
 
 #### Report on what we decided to do.