diff configure.in @ 108792:939ecb6ccd4d

Replace YMF_PASS_LDFLAGS with autoconf. * configure.in (YMF_PASS_LDFLAGS): Remove. (PRE_EDIT_LDFLAGS, POST_EDIT_LDFLAGS): New output variables. * configure: Regenerate. * src/Makefile.in (YMF_PASS_LDFLAGS): Remove. (temacs${EXEEXT}): Use PRE_EDIT_LDFLAGS, POST_EDIT_LDFLAGS. * msdos/sed1v2.inp (@PRE_EDIT_LDFLAGS@, @POST_EDIT_LDFLAGS@): Edit to nothing.
author Glenn Morris <rgm@gnu.org>
date Tue, 25 May 2010 23:41:58 -0700
parents 1b3be6d705bd
children d38bcb4008ab
line wrap: on
line diff
--- a/configure.in	Tue May 25 21:06:09 2010 -0700
+++ b/configure.in	Tue May 25 23:41:58 2010 -0700
@@ -3335,11 +3335,9 @@
     ;;
 esac
 
-## A macro which other sections of Makefile can redefine to munge the
-## flags before they are passed to LD.  This is helpful if you have
-## redefined LD to something odd, like "gcc".
-## (The YMF prefix is a holdover from the old name "ymakefile".) 
-YMF_PASS_LDFLAGS=flags
+
+PRE_EDIT_LDFLAGS=
+POST_EDIT_LDFLAGS=
 if test "x$ORDINARY_LINK" = "xyes"; then
 
   LINKER="\$(CC)"
@@ -3363,10 +3361,12 @@
   ## shell''s ``for'' construct.  Note that sane people do not have '.' in
   ## their paths, so we must use ./prefix-args.
   ## TODO either make prefix-args check ORDINARY_LINK internally,
-  ## or remove it altogether (bug#6184), removing the need for this macro.
-  YMF_PASS_LDFLAGS='`./prefix-args -Xlinker flags`'
+  ## or remove it altogether (bug#6184), removing the need for this hack.
+  PRE_EDIT_LDFLAGS='`./prefix-args -Xlinker'
+  POST_EDIT_LDFLAGS='`'
 fi
-AC_SUBST(YMF_PASS_LDFLAGS)
+AC_SUBST(PRE_EDIT_LDFLAGS)
+AC_SUBST(POST_EDIT_LDFLAGS)
 
 test "x$LINKER" = "x" && LINKER=ld
 ## FIXME? What setting of YMF_PASS_LDFLAGS should this have?