diff configure.in @ 97351:945ae0a5779f

* configure.in: Correctly handle --enable-cocoa-experimental-ctrl-g=no and --enable-ns-self-contained=yes. * configure: Regenerate.
author Andreas Schwab <schwab@suse.de>
date Thu, 07 Aug 2008 08:54:11 +0000
parents ac1bfb10ff9e
children 0defde3a9c5f
line wrap: on
line diff
--- a/configure.in	Thu Aug 07 07:18:07 2008 +0000
+++ b/configure.in	Thu Aug 07 08:54:11 2008 +0000
@@ -153,12 +153,12 @@
 
 dnl Can remove these in Emacs 24.
 AC_ARG_WITH([gtk],,
-  AC_MSG_ERROR([--with-gtk has been removed.  Use --with-x-toolkit to
-specify a toolkit.]),,)
+  [AC_MSG_ERROR([--with-gtk has been removed.  Use --with-x-toolkit to
+specify a toolkit.])],,)
 
 AC_ARG_WITH([gcc],,
-  AC_MSG_ERROR([--with-gcc has been removed.  Set the `CC' environment
-  variable to specify a compiler.]),,)
+  [AC_MSG_ERROR([--with-gcc has been removed.  Set the `CC' environment
+variable to specify a compiler.])],,)
 
 AC_ARG_WITH([pkg-config-prog],dnl
 [AS_HELP_STRING([--with-pkg-config-prog=PATH],
@@ -170,13 +170,15 @@
 fi
 
 AC_ARG_ENABLE(cocoa-experimental-ctrl-g,
-[  --enable-cocoa-experimental-ctrl-g        enable experimental improved ctrl-g recognition],
-   EN_COCOA_EXPERIMENTAL_CTRL_G=yes,
+[AS_HELP_STRING([--enable-cocoa-experimental-ctrl-g],
+                [enable experimental improved ctrl-g recognition])],
+   EN_COCOA_EXPERIMENTAL_CTRL_G=$enableval,
    EN_COCOA_EXPERIMENTAL_CTRL_G=no)
 
 AC_ARG_ENABLE(ns-self-contained,
-[  --disable-ns-self-contained        disable self contained build under NS],
-   EN_NS_SELF_CONTAINED=no,
+[AS_HELP_STRING([--disable-ns-self-contained],
+                [disable self contained build under NeXTstep])],
+   EN_NS_SELF_CONTAINED=$enableval,
    EN_NS_SELF_CONTAINED=yes)
 
 AC_ARG_ENABLE(asserts,