diff configure.in @ 77319:959967514f51

Signal error if Xaw libs are missing in a Lucid build.
author Chong Yidong <cyd@stupidchicken.com>
date Thu, 19 Apr 2007 18:07:26 +0000
parents 972bc1b04abc
children e3ebefd1a410 72cdb7d8d8f0 5a45becb5728 e6fdae9180d4
line wrap: on
line diff
--- a/configure.in	Thu Apr 19 18:07:16 2007 +0000
+++ b/configure.in	Thu Apr 19 18:07:26 2007 +0000
@@ -2206,7 +2206,7 @@
 
 dnl Do not put whitespace before the #include statements below.
 dnl Older compilers (eg sunos4 cc) choke on it.
-if test x"${USE_X_TOOLKIT}" = xmaybe; then
+if test x"${USE_X_TOOLKIT}" = xmaybe || test x"${USE_X_TOOLKIT}" = xLUCID; then
   if test x"${HAVE_X11R5}" = xyes; then
     AC_MSG_CHECKING(X11 version 5 with Xaw)
     AC_CACHE_VAL(emacs_cv_x11_version_5_with_xaw,
@@ -2220,8 +2220,12 @@
       AC_MSG_RESULT([5 or newer, with Xaw; use toolkit by default])
       USE_X_TOOLKIT=LUCID
     else
-      AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
-      USE_X_TOOLKIT=none
+      if test x"${USE_X_TOOLKIT}" = xLUCID; then
+        AC_MSG_ERROR([Lucid toolkit requires X11/Xaw include files])
+      else
+        AC_MSG_RESULT(before 5 or no Xaw; do not use toolkit by default)
+        USE_X_TOOLKIT=none
+      fi
     fi
   else
     USE_X_TOOLKIT=none