diff configure.in @ 81517:978aad8a0332

Complain if X seems to be installed but no development files where found.
author Jan Djärv <jan.h.d@swipnet.se>
date Wed, 20 Jun 2007 19:38:16 +0000
parents 6410d179cb23
children 2c694b2926c7
line wrap: on
line diff
--- a/configure.in	Wed Jun 20 19:36:28 2007 +0000
+++ b/configure.in	Wed Jun 20 19:38:16 2007 +0000
@@ -1892,6 +1892,22 @@
   ;;
 esac
 
+if test "$window_system" = none && test "X$with_x" != "Xno"; then
+   AC_CHECK_PROG(HAVE_XSERVER, X, true, false)
+   if test "$HAVE_XSERVER" = true ||
+      test -n "$DISPLAY" || 
+      test "`echo /usr/lib/libX11.*`" != "/usr/lib/libX11.*"; then
+        AC_MSG_ERROR([You seem to be running X, but no X development libraries
+where found.  You should install the relevant development files for X
+and the for the toolkit you want, such as Gtk+, Lesstif or Motif.  Also make
+sure you have development files for image handling, i.e.
+tiff, gif, jpeg, png and xpm.
+If you are sure you want Emacs compiled without X window support, pass
+  --without-x
+to configure.])
+   fi
+fi
+
 ### If we're using X11, we should use the X menu package.
 HAVE_MENUS=no
 case ${HAVE_X11} in