diff configure.in @ 29990:98af0f021739

* configure.in: Add ${C_SWITCH_X_SITE} temporarily to CPPFLAGS, while searching for image-handling libraries.
author Ken Raeburn <raeburn@raeburn.org>
date Fri, 30 Jun 2000 22:02:25 +0000
parents f660cfaca2db
children 61037d088180
line wrap: on
line diff
--- a/configure.in	Fri Jun 30 20:23:44 2000 +0000
+++ b/configure.in	Fri Jun 30 22:02:25 2000 +0000
@@ -1549,11 +1549,14 @@
 # Change CFLAGS temporarily so that C_SWITCH_X_SITE gets used
 # for the tests that follow.  We set it back to REAL_CFLAGS later on.
 
+REAL_CPPFLAGS="$CPPFLAGS"
+
 if test "${HAVE_X11}" = "yes"; then
   DEFS="$C_SWITCH_X_SITE $DEFS"
   LDFLAGS="$LDFLAGS $LD_SWITCH_X_SITE"
   LIBS="$LIBX $LIBS"
   CFLAGS="$C_SWITCH_X_SITE $CFLAGS"
+  CPPFLAGS="$C_SWITCH_X_SITE $CPPFLAGS"
 
   # On Solaris, arrange for LD_RUN_PATH to point to the X libraries for tests.
   # This is handled by LD_SWITCH_X_SITE_AUX during the real build,
@@ -2061,6 +2064,7 @@
 
 # Set up the CFLAGS for real compilation, so we can substitute it.
 CFLAGS="$REAL_CFLAGS"
+CPPFLAGS="$REAL_CPPFLAGS"
 
 changequote(, )dnl
 #### Find out which version of Emacs this is.