diff configure.in @ 73821:9ba59a3beadd

Prefer X11 to Carbon only when some X-specific option is specified (Thanks to Jan Dj? and Andreas Schwab).
author YAMAMOTO Mitsuharu <mituharu@math.s.chiba-u.ac.jp>
date Wed, 08 Nov 2006 08:02:49 +0000
parents 5e9b94d5f593
children e64942376b6b
line wrap: on
line diff
--- a/configure.in	Wed Nov 08 07:34:24 2006 +0000
+++ b/configure.in	Wed Nov 08 08:02:49 2006 +0000
@@ -1779,7 +1779,13 @@
 if test "${window_system}" = x11 && test "${HAVE_CARBON}" = yes; then
   if test "${with_carbon+set}" != set \
      && test "${carbon_appdir_x+set}" != set; then
-    HAVE_CARBON=no
+    for var in with_x with_x_toolkit with_gtk with_xim \
+               with_xpm with_jpeg with_tiff with_gif with_png; do
+      if eval test \"\${$var+set}\" = set; then
+        HAVE_CARBON=no
+        break
+      fi
+    done
   fi
 fi
 if test "${HAVE_CARBON}" = yes; then