diff configure.in @ 112030:a456b0a17885

* configure.in: Make gameuser configurable (Bug#7717). * configure: Regenerate
author Chong Yidong <cyd@stupidchicken.com>
date Wed, 29 Dec 2010 19:11:25 +0800
parents d21197a7fc63
children 5e63c33ad48c
line wrap: on
line diff
--- a/configure.in	Wed Dec 29 19:02:48 2010 +0800
+++ b/configure.in	Wed Dec 29 19:11:25 2010 +0800
@@ -45,8 +45,6 @@
 docdir='${datadir}/emacs/${version}/etc'
 gamedir='${localstatedir}/games/emacs'
 
-gameuser=games
-
 dnl OPTION_DEFAULT_OFF(NAME, HELP-STRING)
 dnl Create a new --with option that defaults to being disabled.
 dnl NAME is the base name of the option.  The shell variable with_NAME
@@ -203,6 +201,12 @@
 The default is /usr/lib, or /usr/lib64 on some platforms.])])
 CRT_DIR="${with_crt_dir}"
 
+AC_ARG_WITH(gameuser,dnl
+[AS_HELP_STRING([--with-gameuser=USER],[user for shared game score files])])
+test "X${with_gameuser}" != X && test "${with_gameuser}" != yes \
+  && gameuser="${with_gameuser}"
+test "X$gameuser" = X && gameuser=games
+
 AC_ARG_WITH([gnustep-conf],dnl
 [AS_HELP_STRING([--with-gnustep-conf=PATH],[path to GNUstep.conf; default $GNUSTEP_CONFIG_FILE, or /etc/GNUstep/GNUstep.conf])])
 test "X${with_gnustep_conf}" != X && test "${with_gnustep_conf}" != yes && \