diff configure.in @ 108769:a8af6d66bbd0

Remove LD_SWITCH_SYSTEM_EXTRA. * configure.in (LD_SWITCH_SYSTEM_EXTRA): Remove. (LD_SWITCH_SYSTEM_TEMACS): Put darwin stuff from LD_SWITCH_SYSTEM_EXTRA here instead. * src/Makefile.in (LD_SWITCH_SYSTEM_EXTRA): Remove. (TEMACS_LDFLAGS): Remove LD_SWITCH_SYSTEM_EXTRA. * msdos/sed1v2.inp (LD_SWITCH_SYSTEM_EXTRA): No longer present.
author Glenn Morris <rgm@gnu.org>
date Mon, 24 May 2010 20:46:15 -0700
parents e6ab17110c0d
children 87142531365c
line wrap: on
line diff
--- a/configure.in	Mon May 24 20:38:41 2010 -0700
+++ b/configure.in	Mon May 24 20:46:15 2010 -0700
@@ -3284,6 +3284,20 @@
     headerpad_extra=690
   fi
   LD_SWITCH_SYSTEM_TEMACS="-prebind $libs_nsgui -Xlinker -headerpad -Xlinker $headerpad_extra"
+
+  ## This is here because src/Makefile.in did some extra fiddling around
+  ## with LD_SWITCH_SYSTEM.  The cpp logic was:
+  ##   #ifndef LD_SWITCH_SYSTEM
+  ##   #if !defined (__GNUC__) && ((defined (BSD_SYSTEM) && !defined (COFF)))
+  ## Since all the *bsds define LD_SWITCH_SYSTEM, this simplifies to:
+  ## not using gcc, darwin system not on an alpha (ie darwin, since
+  ## darwin + alpha does not occur).
+  ## Because this was done in src/Makefile.in, the resulting part of
+  ## LD_SWITCH_SYSTEM was not used in configure (ie, in ac_link).
+  ## It therefore seems cleaner to put this in LD_SWITCH_SYSTEM_TEMACS,
+  ## rather than LD_SWITCH_SYSTEM.
+  test "x$LD_SWITCH_SYSTEM" = "x" && test "x$GCC" != "xyes" && \
+    LD_SWITCH_SYSTEM_TEMACS="-X $LD_SWITCH_SYSTEM_TEMACS"
   ;;
 
   *) LD_SWITCH_SYSTEM_TEMACS= ;;
@@ -3291,23 +3305,6 @@
 AC_SUBST(LD_SWITCH_SYSTEM_TEMACS)
 
 
-## This exists because src/Makefile.in did some extra fiddling around
-## with LD_SWITCH_SYSTEM.  The cpp logic was:
-##   #ifndef LD_SWITCH_SYSTEM
-##   #if !defined (__GNUC__) && ((defined (BSD_SYSTEM) && !defined (COFF)))
-## Since all the *bsds define LD_SWITCH_SYSTEM, this simplifies to:
-## not using gcc, darwin system not on an alpha (ie darwin, since
-## darwin + alpha does not occur).
-## Note that unlike L_S_S, this is not used in ac_link.
-if test "x$LD_SWITCH_SYSTEM" = "x" && test "x$GCC" != "xyes" && \
-   test "$opsys" = "darwin"; then
-  LD_SWITCH_SYSTEM_EXTRA="-X"
-else
-  LD_SWITCH_SYSTEM_EXTRA=
-fi
-AC_SUBST(LD_SWITCH_SYSTEM_EXTRA)
-
-
 LINKER=
 ORDINARY_LINK=
 case "$opsys" in