diff configure.in @ 12037:a9ada5749a17

Use x_includes, not x_libraries, for -I. Make bitmapdir a colon-separated list.
author Karl Heuer <kwzh@gnu.org>
date Tue, 30 May 1995 23:26:56 +0000
parents f074fb9f8e83
children 021b6000bd04
line wrap: on
line diff
--- a/configure.in	Tue May 30 23:17:55 1995 +0000
+++ b/configure.in	Tue May 30 23:26:56 1995 +0000
@@ -940,15 +940,24 @@
   LD_SWITCH_X_SITE_AUX=-R`echo ${x_libraries} | sed -e "s/:/ -R/g"`
 fi
 if test "${x_includes}" != NONE && test -n "${x_includes}"; then
-  C_SWITCH_X_SITE=-I`echo ${x_libraries} | sed -e "s/:/ -I/g"`
+  C_SWITCH_X_SITE=-I`echo ${x_includes} | sed -e "s/:/ -I/g"`
 fi
 
 if test x"${x_includes}" = x; then
   bitmapdir=/usr/include/X11/bitmaps
-elif test -d "${x_includes}/X11/bitmaps"; then
-  bitmapdir="${x_includes}/X11/bitmaps"
 else
-  bitmapdir="${x_includes}/bitmaps"
+  # accumulate include directories that have X11 bitmap sudirectories
+  bmd_acc="dummyval"
+  for bmd in `echo ${x_includes} | sed -e "s/:/ /g"`; do
+    if test -d "${bmd}/X11/bitmaps"; then
+      bmd_acc="${bmd_acc}:${bmd}/X11/bitmaps"
+    elif test -d "${bmd}/bitmaps"; then
+      bmd_acc="${bmd_acc}:${bmd}/bitmaps"
+    fi
+  done
+  if test ${bmd_acc} != "dummyval"; then
+    bitmapdir=`echo ${bmd_acc} | sed -e "s/^dummyval://"`
+  fi
 fi
 
 case "${window_system}" in