diff configure.in @ 53071:aa5d7d8f5736

* configure.in (HAVE_GTK_MULTIDISPLAY): Check if GTK can handle multiple displays. Regenerate configure.
author Jan Djärv <jan.h.d@swipnet.se>
date Sun, 16 Nov 2003 16:09:07 +0000
parents ae8115a00e62
children b1025973e761
line wrap: on
line diff
--- a/configure.in	Sun Nov 16 16:06:58 2003 +0000
+++ b/configure.in	Sun Nov 16 16:09:07 2003 +0000
@@ -1915,13 +1915,24 @@
   AC_SUBST(GTK_CFLAGS)
   AC_SUBST(GTK_LIBS)
   C_SWITCH_X_SITE="$C_SWITCH_X_SITE $GTK_CFLAGS"
+  CFLAGS="$CFLAGS $GTK_CFLAGS"
+  LIBS="$GTK_LIBS $LIBS"
   HAVE_GTK=yes
   AC_DEFINE(HAVE_GTK, 1, [Define to 1 if using GTK.])
   USE_X_TOOLKIT=none
 
-  dnl  GTK scrollbars resembles toolkit scrollbars alot, so to avoid
+  dnl  GTK scrollbars resemble toolkit scrollbars a lot, so to avoid
   dnl  a lot if #ifdef:s, say we have toolkit scrollbars.
   with_toolkit_scroll_bars=yes
+
+  dnl  Check if we can use multiple displays with this GTK version.
+  dnl  If gdk_display_open exists, assume all others are there also.
+  HAVE_GTK_MULTIDISPLAY=no
+  AC_CHECK_FUNCS(gdk_display_open, HAVE_GTK_MULTIDISPLAY=yes)
+  if test "${HAVE_GTK_MULTIDISPLAY}" = "yes"; then
+    AC_DEFINE(HAVE_GTK_MULTIDISPLAY, 1,
+              [Define to 1 if GTK can handle more than one display.])
+  fi
 fi
 
 dnl Do not put whitespace before the #include statements below.