diff configure.in @ 108475:b246058e9b05

Do not preprocess lib-src/Makefile.in * configure.in: Generate lib-src/Makefile directly, do not run cpp. * config.bat: Do not run cpp on lib-src/Makefile.in. * lib-src/Makefile.in: Convert comments to makefile format. * admin/notes/cpp: lib-src/Makefile not preprocessed.
author Glenn Morris <rgm@gnu.org>
date Mon, 10 May 2010 20:00:32 -0700
parents b9b3b94979ee
children ea7b1bab920f
line wrap: on
line diff
--- a/configure.in	Mon May 10 19:51:08 2010 -0700
+++ b/configure.in	Mon May 10 20:00:32 2010 -0700
@@ -3595,7 +3595,7 @@
 	CPP_NEED_TRADITIONAL=no,
 	CPP_NEED_TRADITIONAL=yes)
 
-AC_OUTPUT(Makefile lib-src/Makefile.c:lib-src/Makefile.in oldXMenu/Makefile \
+AC_OUTPUT(Makefile lib-src/Makefile oldXMenu/Makefile \
 	doc/emacs/Makefile doc/misc/Makefile doc/lispintro/Makefile \
 	doc/lispref/Makefile src/Makefile.c:src/Makefile.in \
 	lwlib/Makefile lisp/Makefile leim/Makefile, [
@@ -3619,22 +3619,6 @@
   CPPFLAGS="$CPPFLAGS -traditional"
 fi
 
-echo creating lib-src/Makefile
-( cd lib-src
-  rm -f junk.c junk1.c junk2.c
-  sed -e '/start of cpp stuff/q' \
-      < Makefile.c > junk1.c
-  sed -e '1,/start of cpp stuff/d'\
-      -e 's,/\*\*/#\(.*\)$,/* \1 */,' \
-      < Makefile.c > junk.c
-  $CPP -P $cpp_undefs -I. -I$srcdir/src $CPPFLAGS junk.c | \
-      sed -e 's/^ /	/' -e '/^#/d' -e '/^[ 	]*$/d' > junk2.c
-  cat junk1.c junk2.c > Makefile.new
-  rm -f junk.c junk1.c junk2.c
-  chmod 444 Makefile.new
-  mv -f Makefile.new Makefile
-)
-
 echo creating src/Makefile
 ( cd src
   rm -f junk.c junk1.c junk2.c