diff configure.in @ 104556:b54f03a2c09a

* configure.in: Warn if package version specified here doesn't match the version in version.el. * configure: Regenerate.
author Ken Raeburn <raeburn@raeburn.org>
date Sun, 23 Aug 2009 02:15:00 +0000
parents a292f04f1224
children fe2a0bec5d65
line wrap: on
line diff
--- a/configure.in	Sun Aug 23 00:45:17 2009 +0000
+++ b/configure.in	Sun Aug 23 02:15:00 2009 +0000
@@ -2551,6 +2551,9 @@
 if test x"${version}" = x; then
   AC_MSG_ERROR([can't find current emacs version in `${srcdir}/lisp/version.el'.])
 fi
+if test x"${version}" != x"$PACKAGE_VERSION"; then
+  AC_MSG_WARN([version mismatch between `${srcdir}/configure.in' and `${srcdir}/lisp/version.el'.])
+fi
 
 ### Specify what sort of things we'll be editing into Makefile and config.h.
 ### Use configuration here uncanonicalized to avoid exceeding size limits.