diff configure.in @ 112403:c81ff7082a9a

src/config.in: shrink slightly * configure.in: Invoke the new gnulib macro gl_ASSERT_NO_GNULIB_TESTS. This makes src/config.in a bit smaller, by removing identifiers like GNULIB_TEST_MKTIME that Emacs does not need. * m4/getopt.m4, m4/gnulib-common.m4, m4/include_next.m4: * m4/multiarch.m4, m4/stddef_h.m4, m4/time_h.m4, m4/unistd_h.m4: Sync from gnulib. This removes a few more unnecessary symbols from src/config.in, such as AA_APPLE_UNIVERSAL_BUILD and HAVE_STDDEF_H. * configure, src/config.in: Regenerate.
author Paul Eggert <eggert@cs.ucla.edu>
date Fri, 21 Jan 2011 16:12:10 -0800
parents 19348bd13f81
children 7aa0a7abfb6d
line wrap: on
line diff
--- a/configure.in	Fri Jan 21 12:27:07 2011 -0800
+++ b/configure.in	Fri Jan 21 16:12:10 2011 -0800
@@ -877,11 +877,11 @@
    # emacs, instead of the generic ELF dump code found in unexelf.c.
    # The resulting binary has a complete symbol table, and is better
    # for debugging and other observability tools (debuggers, pstack, etc).
-   # 
+   #
    # If you encounter a problem using dldump(), please consider sending
    # a message to the OpenSolaris tools-linking mailing list:
    #      http://mail.opensolaris.org/mailman/listinfo/tools-linking
-   # 
+   #
    # It is likely that dldump() works with older Solaris too, but this has
    # not been tested, so for now this change is for Solaris 10 or newer.
    UNEXEC_OBJ=unexsol.o
@@ -948,7 +948,7 @@
       AC_MSG_ERROR([What gives?  Fix me if DEC Unix supports ELF now.])
     fi
   else
-    UNEXEC_OBJ=unexalpha.o 
+    UNEXEC_OBJ=unexalpha.o
   fi
 fi
 AC_SUBST(C_SWITCH_MACHINE)
@@ -1130,7 +1130,7 @@
 
 if test "${with_sound}" != "no"; then
   # Sound support for GNU/Linux and the free BSDs.
-  AC_CHECK_HEADERS(machine/soundcard.h sys/soundcard.h soundcard.h, 
+  AC_CHECK_HEADERS(machine/soundcard.h sys/soundcard.h soundcard.h,
     have_sound_header=yes)
   # Emulation library used on NetBSD.
   AC_CHECK_LIB(ossaudio, _oss_ioctl, LIBSOUND=-lossaudio, LIBSOUND=)
@@ -1817,7 +1817,7 @@
     PKG_CHECK_MODULES(IMAGEMAGICK, $IMAGEMAGICK_MODULE, HAVE_IMAGEMAGICK=yes, :)
     AC_SUBST(IMAGEMAGICK_CFLAGS)
     AC_SUBST(IMAGEMAGICK_LIBS)
-  
+
     if test $HAVE_IMAGEMAGICK = yes; then
       AC_DEFINE(HAVE_IMAGEMAGICK, 1, [Define to 1 if using imagemagick.])
       CFLAGS="$CFLAGS $IMAGEMAGICK_CFLAGS"
@@ -2670,6 +2670,7 @@
 AC_FUNC_GETPGRP
 
 # Configure gnulib.
+gl_ASSERT_NO_GNULIB_TESTS
 gl_INIT
 
 AC_FUNC_STRFTIME
@@ -3241,7 +3242,7 @@
 
 if test "$HAVE_GTK" = "yes" || test "$HAVE_MENUS" != "yes"; then
   OLDXMENU_TARGET=
-  OLDXMENU=nothing  
+  OLDXMENU=nothing
   LIBXMENU=
   OLDXMENU_DEPS=
 fi
@@ -3305,7 +3306,7 @@
      headerpad_extra=690
    fi
    LD_SWITCH_SYSTEM_TEMACS="-prebind $libs_nsgui -Xlinker -headerpad -Xlinker $headerpad_extra"
- 
+
    ## This is here because src/Makefile.in did some extra fiddling around
    ## with LD_SWITCH_SYSTEM.  The cpp logic was:
    ##   #ifndef LD_SWITCH_SYSTEM