diff configure.in @ 106514:d079dad917ed

configure.in: Don't check for RSVG or GConf unless X11 is used.
author Jan Djärv <jan.h.d@swipnet.se>
date Wed, 09 Dec 2009 18:46:53 +0000
parents 2400073344ef
children 12138f085fa7
line wrap: on
line diff
--- a/configure.in	Wed Dec 09 14:30:37 2009 +0000
+++ b/configure.in	Wed Dec 09 18:46:53 2009 +0000
@@ -1610,7 +1610,7 @@
 
 ### Use -lrsvg-2 if available, unless `--with-rsvg=no' is specified.
 HAVE_RSVG=no
-if test "${HAVE_X11}" = "yes" || test "${HAVE_NS}" = "yes"; then
+if test "${HAVE_X11}" = "yes"; then
   if test "${with_rsvg}" != "no"; then
     RSVG_REQUIRED=2.11.0
     RSVG_MODULE="librsvg-2.0 >= $RSVG_REQUIRED"
@@ -1756,7 +1756,7 @@
 dnl GConf has been tested under GNU/Linux only.
 dnl The version is really arbitrary, it is about the same age as Gtk+ 2.6.
 HAVE_GCONF=no
-if test "X$with_x" != "Xno" && test "${with_gconf}" = "yes"; then
+if test "${HAVE_X11}" = "yes" && test "${with_gconf}" = "yes"; then
    PKG_CHECK_MODULES(GCONF, gconf-2.0 >= 2.13, HAVE_GCONF=yes, HAVE_GCONF=no)
    if test "$HAVE_GCONF" = yes; then
       AC_DEFINE(HAVE_GCONF, 1, [Define to 1 if using GConf.])