diff configure.in @ 96923:d89afa2b4c2f

* config.in: Regenerate. * s/ms-w32.h (subprocesses): Define unconditionally. * s/template.h (subprocesses): Update comment. * s/vms.h (subprocesses): * s/usg5-4.h (subprocesses): * s/hpux10-20.h (subprocesses): * s/gnu-linux.h (subprocesses): * s/cygwin.h (subprocesses): * s/bsd-common.h (subprocesses): * s/aix4-2.h (subprocesses): * s/darwin.h (subprocesses): Do not define, defined by default now. * Makefile.in (C_SWITCH_SITE, LD_SWITCH_SITE): Remove, unused. Remove all references. (temacs): Add GNUStep specific ld flags. * Makefile.in (ALL_CFLAGS): Remove reference to C_SWITCH_SITE. * config.nt (C_SWITCH_SITE, LD_SWITCH_SITE): Do not undefine. * Makefile.in (ALL_CFLAGS): Remove reference to C_SWITCH_SITE. * configure.in (LD_SWITCH_SITE): Remove, set the values directly in src/Makefile.in. (static): Remove, autoconf would always comment it out anyway. (subprocesses): Define unconditionally.
author Dan Nicolaescu <dann@ics.uci.edu>
date Wed, 23 Jul 2008 06:26:32 +0000
parents 0fd239831a6e
children 10d82debd64e
line wrap: on
line diff
--- a/configure.in	Wed Jul 23 06:23:38 2008 +0000
+++ b/configure.in	Wed Jul 23 06:26:32 2008 +0000
@@ -2589,7 +2589,7 @@
 #define CANNOT_DUMP
 #endif
 
-/* PENDING: These are used for the Carbon port only. */
+/* TODO: These are used for the Carbon port only. */
 #undef MAC_OS
 #undef MAC_OSX
 
@@ -2645,7 +2645,6 @@
 # ifdef NS_IMPL_GNUSTEP
 /* See also .m.o rule in Makefile.in */
 #  define C_SWITCH_X_SYSTEM -MMD -MP -D_REENTRANT -fPIC -fno-strict-aliasing
-#  define LD_SWITCH_SITE -lgnustep-gui -lgnustep-base -lobjc $(CONFIG_SYSTEM_LIBS) -lpthread
 #  define GNU_OBJC_CFLAGS -fgnu-runtime -Wno-import -fconstant-string-class=NSConstantString -DGNUSTEP_BASE_LIBRARY=1 -DGNU_GUI_LIBRARY=1 -DGNU_RUNTIME=1 -DGSWARN -DGSDIAGNOSE
 #  define OTHER_FILES ns-app
 # else /* NS_IMPL_COCOA */
@@ -2654,25 +2653,12 @@
 # endif /* NS_IMPL_COCOA */
 #endif /* HAVE_NS */
 
-
-
-/* If no remapping takes place, static variables cannot be dumped as
-   pure, so don't worry about the `static' keyword. */
-#ifdef NO_REMAP
-#undef static
-#endif
-
 /* Define `subprocesses' should be defined if you want to
    have code for asynchronous subprocesses
    (as used in M-x compile and M-x shell).
-   These do not work for some USG systems yet;
-   for the ones where they work, the s/SYSTEM.h file defines this flag.  */
-
-#ifndef VMS
-#ifndef USG
-/* #define subprocesses */
-#endif
-#endif
+   Only MSDOS does not support this.  */
+
+#define subprocesses
 
 /* SIGTYPE is the macro we actually use.  */
 #ifndef SIGTYPE