diff configure.in @ 89989:e23928ac5a97

Revision: miles@gnu.org--gnu-2004/emacs--unicode--0--patch-47 Merge from emacs--cvs-trunk--0 Patches applied: * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-571 Merge from gnus--rel--5.10 * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-572 - miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-574 Update from CVS * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-575 Merge from gnus--rel--5.10 * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-576 - miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-579 Update from CVS * miles@gnu.org--gnu-2004/emacs--cvs-trunk--0--patch-580 Merge from gnus--rel--5.10 * miles@gnu.org--gnu-2004/gnus--rel--5.10--patch-31 - miles@gnu.org--gnu-2004/gnus--rel--5.10--patch-33 Update from CVS * miles@gnu.org--gnu-2004/gnus--rel--5.10--patch-34 Merge from emacs--cvs-trunk--0 * miles@gnu.org--gnu-2004/gnus--rel--5.10--patch-35 - miles@gnu.org--gnu-2004/gnus--rel--5.10--patch-37 Update from CVS
author Miles Bader <miles@gnu.org>
date Wed, 29 Sep 2004 07:22:20 +0000
parents 0b158db81c28 4408561037cf
children 6c1af301b455
line wrap: on
line diff
--- a/configure.in	Tue Sep 28 04:38:25 2004 +0000
+++ b/configure.in	Wed Sep 29 07:22:20 2004 +0000
@@ -1288,13 +1288,22 @@
 
 dnl check if exec-shield is present.
 AC_CHECK_FILE(/proc/sys/kernel/exec-shield, emacs_cv_execshield=1,
-					    emacs_cv_execshield=0)
+                                            emacs_cv_execshield=0)
 if test "$emacs_cv_execshield" = 1; then
-   AC_PATH_PROG(SETARCH, setarch, no)
-   AC_SUBST(SETARCH)
-   if test "$setarch" != no; then
-     AC_DEFINE(HAVE_EXECSHIELD, 1, [Define to 1 if this OS has exec shield.])
-   fi
+  AC_PATH_PROG(SETARCH, setarch, no)
+  AC_SUBST(SETARCH)
+  if test "$setarch" != no && test "$machine" = "intel386"; then
+    AC_DEFINE(HAVE_EXECSHIELD, 1,
+    [Define to 1 if this OS has exec shield and we can handle it.])
+  else
+    case "`cat /proc/sys/kernel/exec-shield`" in
+      0) ;;
+      *)
+        AC_MSG_ERROR([Exec-shield is turned on.
+Emacs can not dump itself if exec-shield is turned on.
+See `etc/PROBLEMS' for further information.])
+    esac
+  fi
 fi
 
 #### Extract some information from the operating system and machine files.