diff configure.in @ 105623:e5d284379e14

(NS_HAVE_NSINTEGER): Back out previous change. (*-apple-darwin*): Add x86_64 architecture.
author Adrian Robert <Adrian.B.Robert@gmail.com>
date Fri, 16 Oct 2009 03:08:41 +0000
parents a8741022610c
children 18fec2baa411
line wrap: on
line diff
--- a/configure.in	Fri Oct 16 02:20:29 2009 +0000
+++ b/configure.in	Fri Oct 16 03:08:41 2009 +0000
@@ -456,6 +456,7 @@
     case "${canonical}" in
       i[3456]86-* )  machine=intel386 ;;
       powerpc-* )    machine=macppc ;;
+      x86_64-* )     machine=amdx86-64 ;;
       * )            unported=yes ;;
     esac
     opsys=darwin
@@ -1339,6 +1340,14 @@
   AC_CHECK_HEADER([AppKit/AppKit.h], [HAVE_NS=yes],
   		  [AC_MSG_ERROR([`--with-ns' was specified, but the include
   files are missing or cannot be compiled.])])
+  NS_HAVE_NSINTEGER=yes
+  AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <Foundation/NSObjCRuntime.h>],
+                                     [NSInteger i;])],
+		    ns_have_nsinteger=yes,
+		    ns_have_nsinteger=no)
+  if test $ns_have_nsinteger = no; then
+    NS_HAVE_NSINTEGER=no
+  fi
 fi
 if test "${HAVE_NS}" = yes; then
   window_system=nextstep