diff configure.in @ 51690:e6a0d3015a99

Fix XRegisterIMInstantiateCallback check for gcc.
author Dave Love <fx@gnu.org>
date Sun, 29 Jun 2003 12:01:08 +0000
parents 8e29225b8438
children 1167403cc11b
line wrap: on
line diff
--- a/configure.in	Sun Jun 29 10:37:00 2003 +0000
+++ b/configure.in	Sun Jun 29 12:01:08 2003 +0000
@@ -2049,6 +2049,10 @@
 if test "${with_xim}" != "no"; then
   AC_DEFINE(USE_XIM, 1,
 	    [Define to 1 if we should use XIM, if it is available.])
+  late_CFLAGS=$CFLAGS
+  if test "$GCC" = yes; then
+    CFLAGS="$CFLAGS --pedantic-errors"
+  fi
   AC_TRY_COMPILE([
 #include <X11/Xlib.h>
 #include <X11/Xresource.h>],
@@ -2058,6 +2062,12 @@
 char *res_class;
 XIMProc  callback;
 XPointer *client_data;
+#ifndef __GNUC__
+/* If we're not using GCC, it's probably not XFree86, and this is
+   probably right, but we can't use something like --pedantic-errors.  */
+extern Bool XRegisterIMInstantiateCallback(Display*, XrmDatabase, char*,
+                                           char*, XIMProc, XPointer*);
+#endif
 (void)XRegisterIMInstantiateCallback(display, db, res_name, res_class, callback,
    client_data);],
     [emacs_cv_arg6_star=yes])
@@ -2069,6 +2079,7 @@
   else
      AC_DEFINE(XRegisterIMInstantiateCallback_arg6, [XPointer])
   fi
+  CFLAGS=$late_CFLAGS
 fi
 
 ### Use -lXpm if available, unless `--with-xpm=no'.