diff configure.in @ 108740:e6ab17110c0d

* configure.in (MKDEPDIR): Parallel build tweak. * src/Makefile.in: Comment.
author Glenn Morris <rgm@gnu.org>
date Fri, 21 May 2010 09:31:45 -0700
parents c554bb2aba83
children a8af6d66bbd0
line wrap: on
line diff
--- a/configure.in	Fri May 21 16:16:42 2010 +0200
+++ b/configure.in	Fri May 21 09:31:45 2010 -0700
@@ -1376,7 +1376,10 @@
    fi
    if test $ac_enable_autodepend = yes; then
       DEPFLAGS='-MMD -MF ${DEPDIR}/$*.d'
-      MKDEPDIR='test -d ${DEPDIR} || mkdir ${DEPDIR}'
+      ## In parallel builds, another make might create depdir between
+      ## the first test and mkdir, so stick another test on the end.
+      ## Or use mkinstalldirs?  mkdir -p is not portable.
+      MKDEPDIR='test -d ${DEPDIR} || mkdir ${DEPDIR} || test -d ${DEPDIR}'
       deps_frag=autodeps.mk
    fi
 fi