diff configure.in @ 13845:e6b5e975dfa2

Determine HAVE_X11R6. (HAVE_MENUS): Renamed from HAVE_X_MENU.
author Richard M. Stallman <rms@gnu.org>
date Mon, 25 Dec 1995 01:23:18 +0000
parents 7d48799c80b5
children 0a94cd2c51c4
line wrap: on
line diff
--- a/configure.in	Mon Dec 25 01:21:56 1995 +0000
+++ b/configure.in	Mon Dec 25 01:23:18 1995 +0000
@@ -1032,9 +1032,9 @@
 X_TOOLKIT_TYPE=$USE_X_TOOLKIT
 
 ### If we're using X11, we should use the X menu package.
-HAVE_X_MENU=no
+HAVE_MENUS=no
 case ${HAVE_X11} in
-  yes ) HAVE_X_MENU=yes ;;
+  yes ) HAVE_MENUS=yes ;;
 esac
 
 if test "${opsys}" = "hpux9"; then
@@ -1255,6 +1255,17 @@
   AC_CHECK_LIB(Xmu, XmuConvertStandardSelection)
 fi
 
+if test "${window_system}" = "x11"; then
+  AC_MSG_CHECKING(X11 version)
+  AC_TRY_LINK([#include <X11/Xlib.h>],
+[#if XlibSpecificationRelease < 6
+fail;
+#endif
+], [AC_MSG_RESULT(6)
+    AC_DEFINE(HAVE_X11R6)],
+   [AC_MSG_RESULT(not 6)])
+fi
+
 if test "${USE_X_TOOLKIT}" != "none"; then
   AC_MSG_CHECKING(X11 toolkit version)
   AC_TRY_LINK([#include <X11/Intrinsic.h>],
@@ -1419,8 +1430,8 @@
 if test "${HAVE_XFREE386}" = "yes" ; then
   AC_DEFINE(HAVE_XFREE386)
 fi
-if test "${HAVE_X_MENU}" = "yes" ; then
-  AC_DEFINE(HAVE_X_MENU)
+if test "${HAVE_MENUS}" = "yes" ; then
+  AC_DEFINE(HAVE_MENUS)
 fi
 if test "${GNU_MALLOC}" = "yes" ; then
   AC_DEFINE(GNU_MALLOC)