diff configure.in @ 57864:eee018b36c35

* configure.in (HAVE_GTK_FILE_CHOOSER, $HAVE_GTK_FILE_SELECTION): New tests for new and old GTK file dialogs. * configure: Rebuild
author Jan Djärv <jan.h.d@swipnet.se>
date Tue, 02 Nov 2004 07:33:51 +0000
parents a17f324d7b7f
children 2cc8d9bbb72b
line wrap: on
line diff
--- a/configure.in	Tue Nov 02 01:15:04 2004 +0000
+++ b/configure.in	Tue Nov 02 07:33:51 2004 +0000
@@ -1977,6 +1977,21 @@
     AC_DEFINE(HAVE_GTK_MULTIDISPLAY, 1,
               [Define to 1 if GTK can handle more than one display.])
   fi
+  dnl  Check if we have the old file selection dialog.
+  dnl  If gdk_display_open exists, assume all others are there also.
+  HAVE_GTK_FILE_SELECTION=no
+  AC_CHECK_FUNCS(gtk_file_selection_new, HAVE_GTK_FILE_SELECTION=yes)
+
+  dnl  Check if we have the new file chooser dialog
+  dnl  If gdk_display_open exists, assume all others are there also.
+  HAVE_GTK_FILE_CHOOSER=no
+  AC_CHECK_FUNCS(gtk_file_chooser_dialog_new, HAVE_GTK_FILE_CHOOSER=yes)
+
+  if test "$HAVE_GTK_FILE_SELECTION" = yes \
+     && test "$HAVE_GTK_FILE_CHOOSER" = yes;  then
+    AC_DEFINE(HAVE_GTK_FILE_BOTH, 1,
+              [Define to 1 if GTK has both file selection and chooser dialog.])
+  fi
 fi
 
 dnl Do not put whitespace before the #include statements below.