diff configure.in @ 51486:f36efdc0ae5e

Check for memcpy, mempcpy, mblen, mbrlen. Use AC_FUNC_STRFTIME, AC_STRUCT_TIMEZONE, AC_TYPE_MBSTATE_T. (NLIST_STRUCT): Don't define.
author Dave Love <fx@gnu.org>
date Thu, 05 Jun 2003 16:37:13 +0000
parents 51712cc110e2
children e2e63297c062
line wrap: on
line diff
--- a/configure.in	Thu Jun 05 16:24:51 2003 +0000
+++ b/configure.in	Thu Jun 05 16:37:13 2003 +0000
@@ -2225,11 +2225,11 @@
 rename closedir mkdir rmdir sysinfo \
 random lrand48 bcopy bcmp logb frexp fmod rint cbrt ftime res_init setsid \
 strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
-utimes setrlimit setpgid getcwd getwd shutdown strftime getaddrinfo \
+utimes setrlimit setpgid getcwd getwd shutdown getaddrinfo \
 __fpending mblen mbrlen mbsinit strsignal setitimer ualarm index rindex \
 sendto recvfrom getsockopt setsockopt getsockname getpeername \
 gai_strerror mkstemp getline getdelim mremap memmove fsync bzero \
-memset memcmp memmove difftime)
+memset memcmp memmove difftime memcpy mempcpy mblen mbrlen)
 
 AC_CHECK_HEADERS(sys/un.h)
 
@@ -2244,6 +2244,8 @@
 
 AC_FUNC_GETPGRP
 
+AC_FUNC_STRFTIME
+
 # UNIX98 PTYs.
 AC_CHECK_FUNCS(grantpt)
 
@@ -2378,6 +2380,9 @@
   fi
 fi
 
+# This defines (or not) HAVE_TZNAME and HAVE_TM_ZONE.
+AC_STRUCT_TIMEZONE
+
 dnl Note that AC_STRUCT_TIMEZONE doesn't do what you might expect.
 if test "$ac_cv_func_gettimeofday" = yes; then
   AC_CACHE_CHECK([for struct timezone], emacs_cv_struct_timezone,
@@ -2450,6 +2455,8 @@
 
 AC_CHECK_TYPES(size_t)
 
+AC_TYPE_MBSTATE_T
+
 dnl Restrict could probably be used effectively other than in regex.c.
 AC_CACHE_CHECK([for C restrict keyword], emacs_cv_c_restrict,
   [AC_TRY_COMPILE([void fred (int *restrict x);], [],
@@ -2477,9 +2484,6 @@
      declarations.  Define as empty for no equivalent.])
 fi
 
-AC_CHECK_HEADERS(nlist.h, [AC_DEFINE(NLIST_STRUCT, 1,
-                 [Define to 1 if you have <nlist.h>.])])
-
 dnl Fixme: AC_SYS_POSIX_TERMIOS should probably be used, but it's not clear
 dnl how the tty code is related to POSIX and/or other versions of termios.
 dnl The following looks like a useful start.