diff src/icons/Makefile.am @ 308:6cb3c072be3f

ui_icons.h and icons_inline.h depend on gdk-pixbuf-csource, so add a test for it in configure. Wrap generated headers files with #ifdef/#endif and add a comment related to their auto-generated nature. Make the generation itself quiet, but display a message on error. Make these targets depend on respective Makefile.in.
author zas_
date Fri, 11 Apr 2008 13:07:48 +0000
parents 91563e0e88f2
children
line wrap: on
line diff
--- a/src/icons/Makefile.am	Fri Apr 11 12:31:32 2008 +0000
+++ b/src/icons/Makefile.am	Fri Apr 11 13:07:48 2008 +0000
@@ -35,8 +35,12 @@
 	icon_tools		$(srcdir)/icon_tools.png	\
 	icon_view		$(srcdir)/icon_view.png
 
-icons_inline.h: $(ICONS_INLINE)
-	gdk-pixbuf-csource --raw --extern --build-list $(ICONS_INLINE_PAIRS) > icons_inline.h
+icons_inline.h: $(ICONS_INLINE) Makefile.in
+	@(echo '/* Auto generated file, do not edit */'; echo; \
+	 echo '#ifndef ICONS_INLINE_H'; \
+	 echo '#define ICONS_INLINE_H'; echo; \
+	 $(GDK_PIXBUF_CSOURCE) --raw --extern --build-list $(ICONS_INLINE_PAIRS); \
+	 echo '#endif /* ICONS_INLINE_H */') > $@ || echo "!!! Failed to generate $@ !!!"
 
 noinst_DATA = icons_inline.h
 CLEANFILES = $(noinst_DATA)