Fri, 09 May 2008 08:03:25 +0000 |
zas_ |
Update CODING and HACKING files, and add po/README file for translators.
|
Fri, 09 May 2008 07:46:18 +0000 |
zas_ |
Make lirc_cleanup() and lirc_input_callback() static.
|
Fri, 09 May 2008 07:32:30 +0000 |
zas_ |
Use function(void) instead of function() for declaring functions which
|
Thu, 08 May 2008 22:59:14 +0000 |
zas_ |
In the search results view, hide dimensions column instead of
|
Thu, 08 May 2008 22:49:16 +0000 |
zas_ |
Reset thumbnail column to NULL when hidden.
|
Thu, 08 May 2008 20:21:03 +0000 |
zas_ |
search_status_update(): slightly reduce code redundancy.
|
Thu, 08 May 2008 12:50:25 +0000 |
zas_ |
Use g_ascii_strncasecmp() instead of strncasecmp() where applicable.
|
Thu, 08 May 2008 12:38:34 +0000 |
zas_ |
Use g_ascii_strcasecmp() instead of strcasecmp() where ascii-only strings
|
Wed, 07 May 2008 23:27:26 +0000 |
zas_ |
Replace deprecated functions by their counterparts:
|
Wed, 07 May 2008 22:54:33 +0000 |
zas_ |
Resync po files.
|
Wed, 07 May 2008 22:48:30 +0000 |
zas_ |
Add a way to invert the current selection.
|
Tue, 06 May 2008 23:58:08 +0000 |
zas_ |
Tidy up.
|
Tue, 06 May 2008 23:53:12 +0000 |
zas_ |
French translation was updated.
|
Tue, 06 May 2008 23:52:09 +0000 |
zas_ |
Add trash.c.
|
Tue, 06 May 2008 21:35:31 +0000 |
nadvornik |
moved safe delete functions to separate file
|
Tue, 06 May 2008 20:24:16 +0000 |
nadvornik |
use some of the new functions in filedata.c
|
Tue, 06 May 2008 17:00:55 +0000 |
zas_ |
Allow the user to append or replace comments for a group of selected files.
|
Tue, 06 May 2008 12:31:23 +0000 |
zas_ |
Use a dedicated option to enable keywords and comment saving as XMP tags
|
Tue, 06 May 2008 12:03:39 +0000 |
zas_ |
comment_xmp_read(), comment_xmp_write(): cleanup and improve readibility.
|
Mon, 05 May 2008 21:27:39 +0000 |
zas_ |
French translation was updated, various fixes.
|
Mon, 05 May 2008 20:56:20 +0000 |
zas_ |
Belarusian translation was updated. Thanks to Pavel Piatruk.
|
Mon, 05 May 2008 20:51:51 +0000 |
nadvornik |
started implementation of API for sidecar files
|
Mon, 05 May 2008 20:51:50 +0000 |
zas_ |
Update POTFILES.in (filelist.c -> filedata.c).
|
Mon, 05 May 2008 20:49:40 +0000 |
zas_ |
Modify regen_potfiles.sh to generate a patch instead of
|
Mon, 05 May 2008 19:20:46 +0000 |
nadvornik |
added .gqv to known file types
|
Mon, 05 May 2008 19:11:12 +0000 |
nadvornik |
split filelist.c to filefilter.c and filedata.c
|
Mon, 05 May 2008 09:21:01 +0000 |
zas_ |
Revert wrong patch rev 676.
|
Mon, 05 May 2008 09:12:07 +0000 |
zas_ |
Add an helper script to regenerate POTFILES.in file.
|
Mon, 05 May 2008 08:32:18 +0000 |
zas_ |
Revert patch 675, and correctly fix gtk assertion failure.
|
Mon, 05 May 2008 08:15:52 +0000 |
zas_ |
Fix two memory leaks.
|
Mon, 05 May 2008 07:46:32 +0000 |
zas_ |
Fix Gtk-CRITICAL **: gtk_label_set_text: assertion `GTK_IS_LABEL (label)' failed
|
Sun, 04 May 2008 23:57:20 +0000 |
zas_ |
vficon_release_cb(): use switch() and cleanup.
|
Sun, 04 May 2008 23:20:43 +0000 |
zas_ |
Minor tidyup.
|
Sun, 04 May 2008 23:06:46 +0000 |
zas_ |
Drop unused vficon_select_by_path() and vflist_select_by_path().
|
Sun, 04 May 2008 23:03:36 +0000 |
zas_ |
Minor cleanup.
|
Sun, 04 May 2008 21:54:20 +0000 |
nadvornik |
dropped path_list functions, use filelist functions everywhere
|
Sun, 04 May 2008 19:00:39 +0000 |
zas_ |
Remove unused functions:
|
Sun, 04 May 2008 18:45:06 +0000 |
zas_ |
Drop ViewFileIcon, use ViewFile and ViewFileInfoIcon instead.
|
Sun, 04 May 2008 16:16:07 +0000 |
zas_ |
Drop ViewFileList, use ViewFile and ViewFileInfoList instead.
|
Sun, 04 May 2008 11:47:36 +0000 |
zas_ |
Prepare switch to ViewFile (unused yet).
|
Sun, 04 May 2008 00:32:05 +0000 |
zas_ |
Shorten Edit menu labels, dropping "in ". It will ease
|
Sun, 04 May 2008 00:21:14 +0000 |
zas_ |
Do not show Copy, Move, Rename, Delete, New Folder external commands
|
Sun, 04 May 2008 00:16:37 +0000 |
zas_ |
Use GQ_EDITOR_GENERIC_SLOTS instead of hardcoded value.
|
Sat, 03 May 2008 20:55:16 +0000 |
zas_ |
exif_get_description_by_key(): check for "formatted." prefix, and optimize.
|
Sat, 03 May 2008 20:49:25 +0000 |
zas_ |
exif_get_formatted_by_key(): skip prefix when comparing.
|
Sat, 03 May 2008 20:40:50 +0000 |
zas_ |
Change the prefix of formatted exif tags to a more explicit "formatted." prefix
|
Sat, 03 May 2008 16:58:17 +0000 |
zas_ |
Fix a bug occuring when using certain actions on a collection
|
Sat, 03 May 2008 15:19:35 +0000 |
zas_ |
Move marks-related fields from _ViewFileInfoList to _ViewFile, since
|
Sat, 03 May 2008 15:17:24 +0000 |
zas_ |
Move common thumbs_* fields from _ViewFileInfoIcon and _ViewFileInfoList
|
Sat, 03 May 2008 15:13:15 +0000 |
zas_ |
Rename thumbs_fd to thumbs_filedata in ViewFileIcon struct to match
|
Sat, 03 May 2008 15:09:21 +0000 |
zas_ |
Remove useless thumbs_list from ViewFileIcon.
|
Sat, 03 May 2008 12:50:52 +0000 |
zas_ |
Add function prototypes (yet unused).
|
Sat, 03 May 2008 12:48:45 +0000 |
zas_ |
Drop redundant vflist_thumbs_set() introduced in revision 649,
|
Sat, 03 May 2008 12:21:22 +0000 |
zas_ |
Remove redundant prototype.
|
Sat, 03 May 2008 11:58:41 +0000 |
zas_ |
Introduce ViewFileInfoList and ViewFileInfoIcon (not used yet).
|
Sat, 03 May 2008 11:34:13 +0000 |
zas_ |
Replace Layout icon_view field by more generic file_view_type.
|
Sat, 03 May 2008 10:31:37 +0000 |
zas_ |
Set thumbs_enabled through new function vflist_thumbs_set() instead
|
Sat, 03 May 2008 09:41:09 +0000 |
zas_ |
Prepare merging of some parts of view_file_list and view_file_icon and
|
Sat, 03 May 2008 08:35:08 +0000 |
zas_ |
Change default positions of dividers since width of the main menu
|
Fri, 02 May 2008 23:11:31 +0000 |
zas_ |
Make exif_rational_to_double() and exif_get_rational_as_double() static.
|