diff doc/Makefile.am @ 1774:a7f7b9c0050c

build documentation with gnome-doc-tool in makefile
author nadvornik
date Fri, 27 Nov 2009 23:27:35 +0000
parents 2ae81598b254
children a210f58165ed
line wrap: on
line diff
--- a/doc/Makefile.am	Sun Nov 22 09:12:22 2009 +0000
+++ b/doc/Makefile.am	Fri Nov 27 23:27:35 2009 +0000
@@ -2,4 +2,23 @@
 
 helpdir = @htmldir@
 
+# empty help_DATA just installs the directory
+help_DATA = 
+
 EXTRA_DIST = docbook2html.sh docbook
+
+html/GuideIndex.html: docbook/GuideIndex.xml
+	rm -rf html; mkdir html && gnome-doc-tool html -o html $(srcdir)/docbook/GuideIndex.xml
+
+html: html/GuideIndex.html
+
+install-data-hook: html
+	cd html; for f in * ; do $(INSTALL_DATA) "$$f" "$(DESTDIR)$(helpdir)/$$f" ; done
+	ln -s GuideIndex.html "$(DESTDIR)$(helpdir)/index.html"
+	
+uninstall-hook:
+	rm "$(DESTDIR)$(helpdir)/"*
+
+clean-local:
+	rm -rf html
+