Mercurial > geeqie
graph
-
Display error dialog with appropriate message when user is trying to open an invalid collection file.Mon, 08 Dec 2008 21:34:32 +0000, by zas_
-
Cosmetic fix.Mon, 08 Dec 2008 21:33:14 +0000, by zas_
-
handle the case when io.open() failsSun, 07 Dec 2008 13:28:04 +0000, by nadvornik
-
disabled the "unused parameter" warnings, they are harmless and nobodySat, 06 Dec 2008 21:24:38 +0000, by nadvornik
-
Rename few variables to make the code more readable.Tue, 02 Dec 2008 19:34:53 +0000, by zas_
-
keyword_list_find() -> find_string_in_list(), return gboolean.Sun, 30 Nov 2008 21:59:28 +0000, by zas_
-
metadata_set_keywords() -> metadata_set(). Use gboolean type for boolean parameters.Sun, 30 Nov 2008 21:52:37 +0000, by zas_
-
Rename most comment_*() functions to more appropriate metadata_*().Sun, 30 Nov 2008 21:43:01 +0000, by zas_
-
Do not hardcode exif formatted prefix.Thu, 27 Nov 2008 19:10:59 +0000, by zas_
-
Fix up sign-related warning.Thu, 27 Nov 2008 12:34:39 +0000, by zas_
-
Fix up unsigned expression always true warning.Thu, 27 Nov 2008 12:34:03 +0000, by zas_
-
Resync .h with .c declarations.Thu, 27 Nov 2008 12:33:07 +0000, by zas_
-
Fix up pointer signedness warnings.Thu, 27 Nov 2008 12:31:27 +0000, by zas_
-
Fix up not a prototype warning.Thu, 27 Nov 2008 12:30:49 +0000, by zas_
-
Remove unused variable.Thu, 27 Nov 2008 12:30:10 +0000, by zas_
-
Fix up deprecated function and not a prototype warnings.Thu, 27 Nov 2008 12:29:38 +0000, by zas_
-
Handle return values better to silent some warnings.Wed, 26 Nov 2008 20:39:50 +0000, by zas_
-
Print a message if chown() or chmod() fail.Wed, 26 Nov 2008 20:38:47 +0000, by zas_
-
Fix up format vs type warning.Wed, 26 Nov 2008 20:37:14 +0000, by zas_
-
Move comments/keywords read and write stuff to new metadata.{c,h}.Tue, 25 Nov 2008 17:32:51 +0000, by zas_
-
Fix up unsigned expression always true/false warnings.Tue, 25 Nov 2008 17:01:03 +0000, by zas_
-
Hide .gqv extension from collection name in collection window title and recent menu list.Sun, 23 Nov 2008 22:05:27 +0000, by zas_
-
Rename wmsubclass and name to role, which corresponds better to the purpose of the parameter as it ends to be passed to gtk_window_set_role().Sun, 23 Nov 2008 16:16:09 +0000, by zas_
-
Drop useless wmclass stuff. Gtk will take care of it and as said in the documentation using gtk_window_set_wmclass() is sort of pointless.Sun, 23 Nov 2008 16:10:29 +0000, by zas_
-
When more than one image is selected, Split Horizontal, Vertical and Quad will use selected images when initialized.Sat, 22 Nov 2008 22:43:18 +0000, by zas_
-
Tidy up.Sat, 22 Nov 2008 22:10:10 +0000, by zas_
-
Use common code for layout_image_setup_split_none() too.Sat, 22 Nov 2008 22:04:21 +0000, by zas_
-
layout_image_setup_split_*(): simplify code.Sat, 22 Nov 2008 21:58:07 +0000, by zas_
-
layout_image_setup_split_*(): move common code to a new function layout_image_setup_split_common().Sat, 22 Nov 2008 21:11:09 +0000, by zas_