comparison debian/rules @ 1:8b1883341c6f

Initial revision
author masneyb
date Mon, 05 Aug 2002 19:46:57 +0000
parents
children c8ec7877432e
comparison
equal deleted inserted replaced
0:674ed97069fd 1:8b1883341c6f
1 #!/usr/bin/make -f
2 # Derived from dh_make example.
3
4 arch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
5
6 #export DH_VERBOSE=1
7 export DH_COMPAT=2
8
9 ggtmp := $(CURDIR)/debian/gftp-gtk
10 gttmp := $(CURDIR)/debian/gftp-text
11
12 CFLAGS := -O2
13 ifneq "$(findstring debug,$(DEB_BUILD_OPTIONS))" ""
14 CFLAGS += -g
15 endif
16 ifeq "$(arch)" "alpha"
17 CFLAGS += -mieee
18 endif
19
20 build: build-stamp
21 build-stamp:
22 dh_testdir
23 CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --mandir='$${prefix}/share/man'
24 $(MAKE)
25 touch $@
26
27 clean:
28 dh_testdir
29 dh_testroot
30 rm -f debian/dirs debian/docs
31 [ ! -f Makefile ] || $(MAKE) distclean
32 dh_clean build-stamp
33
34 install: build-stamp
35 dh_testdir
36 dh_testroot
37 dh_clean -k
38 $(MAKE) install prefix=$(ggtmp)/usr
39 ln -s gftp.1.gz $(ggtmp)/usr/share/man/man1/gftp-gtk.1.gz
40 dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-common \
41 usr/share/locale usr/share/gftp/gftprc usr/share/gftp/bookmarks \
42 usr/share/man/man1/gftp.1 usr/bin/gftp
43 dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-text usr/bin/gftp-text
44 dh_installdirs -pgftp-text usr/share/man/man1
45 ln -s gftp.1.gz $(gttmp)/usr/share/man/man1/gftp-text.1.gz
46 rm -f $(ggtmp)/usr/share/gftp/COPYING # we have the GPL elsewhere
47 find $(ggtmp)/usr -type d -empty | xargs -r rmdir -p --ignore-fail-on-non-empty
48
49 binary-indep:
50 # Nothing to do, no architecture independent packages here.
51 # locales (gftp-common) have endianness
52
53 binary-arch: install
54 dh_testdir
55 dh_testroot
56 dh_installdocs -a
57 dh_installdocs -An -pgftp-gtk -pgftp-text README TODO
58 # dh_installchangelogs -a ChangeLog
59 dh_installmenu -a
60 ifeq "$(findstring nostrip,$(DEB_BUILD_OPTIONS))" ""
61 dh_strip -a
62 endif
63 dh_compress -a
64 dh_fixperms -a
65 dh_installdeb -a
66 dh_shlibdeps -a
67 dh_gencontrol -a
68 dh_md5sums -a
69 dh_builddeb -a
70
71 binary: binary-indep binary-arch
72 .PHONY: build clean binary-indep binary-arch binary install