comparison debian/rules @ 33:c8ec7877432e

2002-10-06 Brian Masney <masneyb@gftp.org> * src/gtk/delete_dialog.c, src/gtk/gftp-gtk.c, src/gtk/misc-gtk.c, src/gtk/transfer.c - Fixed dead-locks with GDK_THREADS_{ENTER,LEAVE} * configure.in, src/gtk/Makefile.am - Use GTHREAD_LIBS 2002-10-03 Brian Masney <masneyb@gftp.org> * Makefile.am - remove intl and m4 directory from subdirs. autogen.sh will automagically add these for me. * autogen.sh - remove check for libtool * configure.in - link in gthread * cvsclean - added this script * *.[ch] - added $Id$ tags * debian/* - updated files from Debian maintainer
author masneyb
date Mon, 07 Oct 2002 10:40:43 +0000
parents 8b1883341c6f
children c226809c03c8
comparison
equal deleted inserted replaced
32:741f7aefa9aa 33:c8ec7877432e
2 # Derived from dh_make example. 2 # Derived from dh_make example.
3 3
4 arch := $(shell dpkg-architecture -qDEB_BUILD_ARCH) 4 arch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
5 5
6 #export DH_VERBOSE=1 6 #export DH_VERBOSE=1
7 export DH_COMPAT=2 7 export DH_COMPAT=3
8 8
9 ggtmp := $(CURDIR)/debian/gftp-gtk 9 ggtmp := $(CURDIR)/debian/gftp-gtk
10 gttmp := $(CURDIR)/debian/gftp-text 10 gttmp := $(CURDIR)/debian/gftp-text
11 11
12 CFLAGS := -O2 12 CFLAGS := -O2
18 endif 18 endif
19 19
20 build: build-stamp 20 build: build-stamp
21 build-stamp: 21 build-stamp:
22 dh_testdir 22 dh_testdir
23 CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --mandir='$${prefix}/share/man' 23 CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --mandir='$${prefix}/share/man' --enable-textport=yes
24 $(MAKE) 24 $(MAKE)
25 touch $@ 25 touch $@
26 26
27 clean: 27 clean:
28 dh_testdir 28 dh_testdir
29 dh_testroot 29 dh_testroot
30 rm -f debian/dirs debian/docs 30 # rm -f debian/dirs debian/docs
31 rm -f debian/dirs
31 [ ! -f Makefile ] || $(MAKE) distclean 32 [ ! -f Makefile ] || $(MAKE) distclean
32 dh_clean build-stamp 33 dh_clean build-stamp
33 34
34 install: build-stamp 35 install: build-stamp
35 dh_testdir 36 dh_testdir
38 $(MAKE) install prefix=$(ggtmp)/usr 39 $(MAKE) install prefix=$(ggtmp)/usr
39 ln -s gftp.1.gz $(ggtmp)/usr/share/man/man1/gftp-gtk.1.gz 40 ln -s gftp.1.gz $(ggtmp)/usr/share/man/man1/gftp-gtk.1.gz
40 dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-common \ 41 dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-common \
41 usr/share/locale usr/share/gftp/gftprc usr/share/gftp/bookmarks \ 42 usr/share/locale usr/share/gftp/gftprc usr/share/gftp/bookmarks \
42 usr/share/man/man1/gftp.1 usr/bin/gftp 43 usr/share/man/man1/gftp.1 usr/bin/gftp
44 dh_installdirs -pgftp-common usr/lib/menu
45
46 # Install menu file manualy into the gftp-common file because
47 # dh_installmenu cannot do it for me
48 install -p -m644 debian/menu debian/gftp-common/usr/lib/menu/gftp
49 echo "# Automatically added by dh_installmenu">> debian/gftp-common.postinst.debhelper
50 sed "" /usr/share/debhelper/autoscripts/postinst-menu >> debian/gftp-common.postinst.debhelper
51 echo '# End automatically added section' >> debian/gftp-common.postinst.debhelper
52 echo "# Automatically added by dh_installmenu">> debian/gftp-common.postrm.debhelper
53 sed "" /usr/share/debhelper/autoscripts/postrm-menu >> debian/gftp-common.postrm.debhelper
54 echo '# End automatically added section' >> debian/gftp-common.postrm.debhelper
55
43 dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-text usr/bin/gftp-text 56 dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-text usr/bin/gftp-text
44 dh_installdirs -pgftp-text usr/share/man/man1 57 dh_installdirs -pgftp-text usr/share/man/man1
45 ln -s gftp.1.gz $(gttmp)/usr/share/man/man1/gftp-text.1.gz 58 ln -s gftp.1.gz $(gttmp)/usr/share/man/man1/gftp-text.1.gz
46 rm -f $(ggtmp)/usr/share/gftp/COPYING # we have the GPL elsewhere 59 rm -f $(ggtmp)/usr/share/gftp/COPYING # we have the GPL elsewhere
47 find $(ggtmp)/usr -type d -empty | xargs -r rmdir -p --ignore-fail-on-non-empty 60 find $(ggtmp)/usr -type d -empty | xargs -r rmdir -p --ignore-fail-on-non-empty
53 binary-arch: install 66 binary-arch: install
54 dh_testdir 67 dh_testdir
55 dh_testroot 68 dh_testroot
56 dh_installdocs -a 69 dh_installdocs -a
57 dh_installdocs -An -pgftp-gtk -pgftp-text README TODO 70 dh_installdocs -An -pgftp-gtk -pgftp-text README TODO
58 # dh_installchangelogs -a ChangeLog 71 dh_installchangelogs -a ChangeLog
59 dh_installmenu -a 72 #dh_installmenu -a --package=gftp-common
60 ifeq "$(findstring nostrip,$(DEB_BUILD_OPTIONS))" "" 73 ifeq "$(findstring nostrip,$(DEB_BUILD_OPTIONS))" ""
61 dh_strip -a 74 dh_strip -a
62 endif 75 endif
63 dh_compress -a 76 dh_compress -a
64 dh_fixperms -a 77 dh_fixperms -a