diff configure.in @ 325:0fcc6468a0af

2003-12-4 Brian Masney <masneyb@gftp.org> * lib/cache.c lib/misc.c lib/protocols.c lib/rfc2068.c lib/rfc959.c lib/sshv2.c lib/sslcommon.c src/text/gftp-text.c src/gtk/chmod_dialog.c src/gtk/gftp-gtk.c src/gtk/menu-items.c src/gtk/misc-gtk.c src/gtk/mkdir_dialog.c src/gtk/rename_dialog.c src/gtk/transfer.c - when calling gftp_lookup_global_option() or gftp_lookup_request_option(), if the value is an integer, declare the variable type to be intptr_t. This fixes a bug on 64bit platforms (from Gwenole Beauchesne <gbeauchesne@mandrakesoft.com>) * lib/config_file.c (gftp_config_file_read_float) - 64bit fixup * configure.in - increment version to 2.0.17pre0. Undefine _GNU_SOURCE. Check for stdint.h. * lib/gftp.h - include stdint.h if it is found on the system. * src/gtk/gftp-gtk.c (CreateToolbar) - on startup, have the host edit box grab the keyboard focus
author masneyb
date Fri, 05 Dec 2003 00:19:48 +0000
parents cc2eeb30b793
children 51bb530a100c
line wrap: on
line diff
--- a/configure.in	Fri Dec 05 00:16:33 2003 +0000
+++ b/configure.in	Fri Dec 05 00:19:48 2003 +0000
@@ -3,7 +3,7 @@
 AC_INIT(lib/gftp.h)
 
 AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(gftp,2.0.16)
+AM_INIT_AUTOMAKE(gftp,2.0.17pre0)
 
 AC_ARG_ENABLE(gtk20, 
               [  --disable-gtk20	  Don't look for GTK+ 2.0 libraries], 
@@ -30,8 +30,6 @@
 
 ALL_LINGUAS="am az ar be bg bn ca cs da de el es fi fr hr hu it ja ko mk ml ms nl no pl pt pt_BR ro ru sk sr sr@Latn sv tr uk zh_CN zh_TW"
 
-AC_DEFINE(_GNU_SOURCE, 1, [Define for setting a GNU environment])
-
 AC_CANONICAL_HOST
 AC_PROG_CC
 AC_AIX
@@ -54,7 +52,7 @@
 AC_HEADER_DIRENT
 AC_HEADER_STDC
 AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS(fcntl.h libutil.h limits.h malloc.h pty.h strings.h sys/ioctl.h sys/time.h unistd.h)
+AC_CHECK_HEADERS(fcntl.h libutil.h limits.h malloc.h pty.h strings.h sys/ioctl.h sys/time.h unistd.h stdint.h)
 
 AC_TYPE_SOCKLEN_T
 AC_TYPE_MODE_T
@@ -285,4 +283,4 @@
 AC_CHECK_PROG(DB2HTML, db2html, true, false)
 AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
 
-AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile lib/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile gftp.spec intl/Makefile po/Makefile.in intl/Makefile po/Makefile.in )
+AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile lib/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile gftp.spec intl/Makefile po/Makefile.in )