diff configure.in @ 781:1f822f137e19

2006-7-20 Brian Masney <masneyb@gftp.org> * configure.in - added configure check for fsplib. Also, removed intl/Makefile and po/Makefile.in from AC_OUTPUT()
author masneyb
date Thu, 20 Jul 2006 10:22:16 +0000
parents e2d5adfaa9a9
children 71e10b29a2f6
line wrap: on
line diff
--- a/configure.in	Thu Jul 20 03:18:52 2006 +0000
+++ b/configure.in	Thu Jul 20 10:22:16 2006 +0000
@@ -73,6 +73,13 @@
 AC_FUNC_UTIME_NULL
 AC_CHECK_FUNCS(gai_strerror getaddrinfo getcwd gettimeofday getwd mkdir mktime putenv rmdir select socket strdup strstr strtod strtol uname grantpt openpty getdtablesize)
 
+# This is needed by fsplib. This check is from configure.ac in that distribution.
+AC_CHECK_TYPE(union semun, ,AC_DEFINE(_SEM_SEMUN_UNDEFINED,1,[Define if you do not have semun in sys/sem.h]),
+[#include <sys/types.h>
+#include <sys/ipc.h>
+#include <sys/sem.h>
+])
+
 if test "x$enable_gtk20" = "xyes" ; then
   PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.0.0, found_glib20=1, found_glib20=0)
 else
@@ -293,4 +300,4 @@
 AC_CHECK_PROG(DB2HTML, db2html, true, false)
 AM_CONDITIONAL(HAVE_DOCBOOK, $DB2HTML)
 
-AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile lib/Makefile lib/fsplib/Makefile src/gftp src/Makefile src/uicommon/Makefile src/gtk/Makefile src/text/Makefile gftp.spec intl/Makefile po/Makefile.in )
+AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile lib/Makefile lib/fsplib/Makefile src/gftp src/Makefile src/uicommon/Makefile src/gtk/Makefile src/text/Makefile gftp.spec)