diff configure.in @ 215:3d6e024dbf31

2003-7-7 Brian Masney <masneyb@gftp.org> * configure.in src/gtk/Makefile.am src/text/Makefile.am - if the OpenSSL libraries are available on the system, link them in and define USE_SSL. The generic SSL engine and the HTTPS protocol checks for this * lib/protocols.c (gftp_get_line) - small fix * lib/rfc2068.c - fixed several bugs in the handling of chunked messages that are spread across multiple packets (the HTTPS protocol unconvered all of these) * lib/sslcommon.c - several fixes and cleanups
author masneyb
date Tue, 08 Jul 2003 02:09:30 +0000
parents 06cdf06a0f31
children f330309d2f17
line wrap: on
line diff
--- a/configure.in	Mon Jul 07 15:15:15 2003 +0000
+++ b/configure.in	Tue Jul 08 02:09:30 2003 +0000
@@ -19,6 +19,10 @@
               [  --disable-textport	  Disable compiling the text port], 
               enable_textport=$enableval, 
               enable_textport="yes")
+AC_ARG_ENABLE(ssl, 
+              [  --disable-ssl		Disable SSL support], 
+              enable_ssl=$enableval, 
+              enable_ssl="yes")
 
 AC_SUBST(PACKAGE)
 AC_SUBST(VERSION)
@@ -260,6 +264,21 @@
 AC_SUBST(GTHREAD_LIBS)
 AC_SUBST(GFTP_GTK)
 
+SSL_LIBS=""
+if test "x$enable_ssl" = "xyes" ; then
+	AC_CHECK_HEADERS(openssl/ssl.h ssl.h)
+
+	if test $ac_cv_header_openssl_ssl_h = yes -o $ac_cv_header_ssl_h = yes ; then
+		AC_CHECK_LIB(ssl, SSL_library_init, SSL_LIBS="-lcrypto -lssl")
+
+		if test "x$SSL_LIBS" != "x" ; then
+			AC_DEFINE(USE_SSL, 1, 
+                                  [define if you want to enable SSL support])
+		fi
+	fi
+fi
+AC_SUBST(SSL_LIBS)
+
 AM_GNU_GETTEXT
 
-AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile lib/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile gftp.spec intl/Makefile po/Makefile.in intl/Makefile po/Makefile.in)
+AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile lib/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile gftp.spec intl/Makefile po/Makefile.in)