diff configure.in @ 57:72f6ca02c83a

2002-11-11 Brian Masney <masneyb@gftp.org> * configure.in - compile GTK+ 2.0 port by default
author masneyb
date Tue, 12 Nov 2002 00:04:44 +0000
parents 450dbe540dd8
children c01d91c10f6c
line wrap: on
line diff
--- a/configure.in	Mon Nov 11 23:16:12 2002 +0000
+++ b/configure.in	Tue Nov 12 00:04:44 2002 +0000
@@ -5,7 +5,7 @@
 AM_CONFIG_HEADER(config.h)
 AM_INIT_AUTOMAKE(gftp,2.0.14)
 
-AC_ARG_ENABLE(gtk20, [  --enable-gtk20	  Try and compile with GTK+ 2.0 if available], enable_gtk20=1, enable_gtk20=0)
+AC_ARG_ENABLE(gtk20, [  --disable-gtk20	  Don't look for GTK+ 2.0 libraries], enable_gtk20=0, enable_gtk20=1)
 AC_ARG_ENABLE(gtkport, [  --disable-gtkport	  Disable compiling the GTK+ port], enable_gtkport=0, enable_gtkport=1)
 AC_ARG_ENABLE(textport, [  --disable-textport	  Disable compiling the text port], enable_textport=0, enable_textport=1)
 AC_ARG_ENABLE(dmalloc, [  --enable-dmalloc	  Enable the dmalloc library], enable_dmalloc=1, enable_dmalloc=0)
@@ -56,23 +56,25 @@
 AC_FUNC_UTIME_NULL
 AC_CHECK_FUNCS(gai_strerror getaddrinfo getcwd gettimeofday getwd mkdir mktime putenv rmdir select socket strdup strstr strtod strtol uname)
 
-if test "x$GFTP_TEXT" = "x" -a "x$enable_gtk20" = "x0" ; then
+if test $enable_gtk20 = 1 ; then
+  PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.0.0, found_glib20=1, found_glib20=0)
+else
+  found_glib20=0;
+fi
+
+if test "x$GFTP_TEXT" = "x" -a $found_glib20 = 0 ; then
   AM_PATH_GLIB(1.2.3, , AC_MSG_ERROR(gFTP needs GLIB 1.2.3 or higher))
 fi
 
-if test "x$enable_gtk20" = "x1" ; then
-  PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.0.0)
-fi
+AC_CHECK_LIB(socket, socket, EXTRA_LIBS="-lsocket")
+  
+AC_CHECK_LIB(nsl, gethostbyname, EXTRA_LIBS="$EXTRA_LIBS -lnsl")
 
 GFTP_TEXT=""
 EXTRA_LIBS=""
 USE_READLINE="yes"
 READLINE_LIBS=""
 if test "x$enable_textport" = "x1" ; then
-  AC_CHECK_LIB(socket, socket, EXTRA_LIBS="-lsocket")
-  
-  AC_CHECK_LIB(nsl, gethostbyname, EXTRA_LIBS="$EXTRA_LIBS -lnsl")
-
   AC_MSG_CHECKING([whether to use readline])
   AC_ARG_WITH(readline,
   [  --with-readline         turn on readline [default=yes, default tries -lncurses, -lcurses, -ltermcap]],
@@ -166,8 +168,8 @@
 GTHREAD_LIBS=""
 
 if test "x$enable_gtkport" = "x1" ; then
-  if test "x$enable_gtk20" = "x1" ; then
-    PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 1.3.8, GFTP_GTK=gftp-gtk)
+  if test $found_glib20 = 1 -a $enable_gtk20 = 1 ; then
+    PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.0.0, GFTP_GTK=gftp-gtk, AC_MSG_ERROR(You have GLIB 2.0 installed but I cannot find GTK+ 2.0. Run configure with --disable-gtk20 or install GTK+ 2.0))
   fi
 
   if test "x$GFTP_GTK" = "x" ; then
@@ -245,4 +247,4 @@
 
 AM_GNU_GETTEXT
 
-AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile lib/Makefile gftp.spec)
+AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile lib/Makefile gftp.spec intl/Makefile po/Makefile.in )